Help with PPTP VPN Server

Hello,

This is my first post here on the forum, and my first problem with the wonderful Virtualmin software system.

I wanted to make use of the PPTP VPN server function that comes with the Virtualmin system. I went ahead and took a look at the module config, and all looked very simple, and I thought that it would be too good to be true, as is often the case with such matters, and it has turned out true in this situation.

What the problem is, is that I can make a connection to the PPTP VPN server, everything works fine in that respect, but once I have established the connection to the server I am not able to access any other machine on the internet other than the PPTP server itself.

Now, this is a problem as I am intending to use this as a VPN server and sell accounts to customers so that they can access the internet and browse through this VPN. It would seem that it is some sort of routing issue (I think, I don’t know) and I haven’t got a clue what to do about it.

I have tried browsing through the configuration pages in the PPTP VPN server section, but I can’t seem to change or find anything that helps to resolve the problem.

I would appreciate it if someone could help me to configure this so that once connected to the VPN, I, or anyone else that connects to it will be able to browse the internet through it.

As it stands, once connected I can ping the machine itself, but by it’s IP only, as there seems to be no DNS available whilst connected to it.

I hope that I have explained myself sufficiently, and I patiently await your replies.

Thanks in advance,

Britfag

Anyone had a read of this yet?

I’ve tried looking through the settings again, but I’m still stumped.

I’ve never used that module, but off the top of my head:

  • Do you have named installed and working? Maybe it’s needed to resolve hostnames…check it with service named status

  • Have you checked your IPtables rules? Maybe it’s blocking outbound traffic?