Help With NameServer (Step By Step)

Can anyone help me out with this??? I’m at a total Loss for how to do this, I’ve read and read and READ…

I have All my DNS records setup great, Mxtoolbox shows 1 Error and that’s SOA that can’t be set with my Regiastrar…

BUT, now I’m getting Aggregate E-mail Reports and they are all Failing because I can’t enter my DKIM/DKIM Key…

SO I really need to Get the NameServer SetUp and Working…

If I get the “meaning” of these wrong it’s do to my confusion on it, But I think I’m at-least close to getting them right…

I have 2 IP’s one is static that I run the forum of of, the other is assigned at boot, and as long as I don’t reset the server it remains the same…

my servername (OS On the VPS) is: “

my website is “

Here is my DNS records from NameSilo


A NA 3600 3rd-party
admin A NA 3600 3rd-party
ftp A NA 3600 3rd-party
m A NA 3600 3rd-party
ns1 A NA 3600 3rd-party
webdisk A NA 3600 3rd-party
webmail A NA 3600 3rd-party
whm A NA 3600 3rd-party
mail CNAME NA 3600 3rd-party
www CNAME NA 3600 3rd-party
MX 10 3600 3rd-party
TXT NA 3600 3rd-party
TXT SOA ( 1471447655 10800
3600 604800 38400 ) NA 3600 3rd-party This One is Useless But I tried
TXT v=spf1 a mx ip4: ?all NA 3600 3rd-party
_dmarc TXT v=DMARC1; p=reject; sp=none;;; rf=afrf; pct=100; ri=86400 NA 3600 3rd-party

Now when I go to add the nameserver, my registrar tells me it doesn’t exist…

Can anyone please guide me on the proper way to do this… I guess, Basically I just need to know HOW to make the nameserver resolve, then I can get the rest on my own…




There’s some info here on how to setup nameservers that should help get you started:

Ya, I’ve read that 20 times or so

In order to use your Virtualmin server as a DNS server, it needs to be setup so that names like and can be input as a domain’s nameservers.

For that to work – you first have to go to the domain name registrar for, and register your server as a nameserver. It’s usually as simple as inputting two or more names (such as and, and the IP addresses that are associated with them.

Ok I did that, I have setup, I’ve even gone to (I think) “NO IP” and registered a NS4 there and tried, No Matter what I do The Nameserver is not being excepted as “existing”

Here’s where my confusion is (I Guess :sunglasses: ) Do I Make a Virtual Server (DOMAIN) and Call it “” then have it the master of my actual (slave) forum with those DNS records?

I was under the impression that if I named my server “” that its an FQDN, which it is, because Virtualmin accepted it fine on install…

When I try to register it as a Nameserver, My Registrar comes back with it’s not a Nameserver…

And As Far as I’ve read you just need an “A” name point to “” and your good…



EDIT: Also I don’t have the “DNS Server” running (or DHCP Server) as the IP is Static, I’m figuring (again from reading) that I don’t need it because my IP isn’t Dynamic… I could be wrong in this,… I’ve looked at it and Though about “Playing” with it, And Say YA RIGHT! LOL

See Searching around again, This is from GoDaddy, Seems like it really should be a simple process…

In the Add New Entries Below this Line section, do the following in the first row: First field: Type ns1 Second field: Type 14400. Third field: Select A. Fourth field: Enter your server's IP address. Then, in the second row, do the following: First field: Type ns2 Second field: Type 14400. Third field: Select A. Fourth field: Enter your server's IP address.

Why not use the nameservers your domain register offers, or even Googles, supposed to be the fastest available.
Always more to a post than meets the eye.

Because my DKIM is Failing with a bunch of the Big search Engines, And my Registrar Doesn’t allow the adding the domainkey…

And now have a new problem, and this has happened before, I decided to activate my Dynamic IP in Virtualmin/Network Settings, and it broke bind, which has happened before, I believe I had to delete something out of the zone file to fix it… working on it now…

My Idea was to have my Registrar Point to the Dynamic IP and try and serve from there, from this post:

But the Answer was never resolved there…

Adding the Second IP:

Aug 30 12:35:05 bash[27651]: zone loaded serial 0 Aug 30 12:35:05 bash[27651]: zone has no NS records Aug 30 12:35:05 bash[27651]: zone not loaded due to errors. Aug 30 12:35:05 bash[27651]: _default/ bad zone Aug 30 12:35:05 bash[27651]: zone loaded serial 1472312758 Aug 30 12:35:05 bash[27651]: zone loaded serial 1472578041 Aug 30 12:35:05 systemd[1]: named.service: control process exited, code=exited status=1 Aug 30 12:35:05 systemd[1]: Failed to start Berkeley Internet Name Domain (DNS). Aug 30 12:35:05 systemd[1]: Unit named.service entered failed state. Aug 30 12:35:05 systemd[1]: named.service failed.

And Love that signature! LOL


EDIT: ACK! I remember how I fixed it, I had to Remove All the Virtual Servers, and Re-Create them, LORD! Knew I shouldn’t have gone playing around with this, Does ANYONE know how to fix this Issue?!?!??!?!

Has DKIM ever worked here :slight_smile: Always had problems myself, but don’t send email a lot and never a problem anyway as all my domains and IP’s I keep clean.

So is this about mass email sortie and response the other end? To put it in a polite way.

Not really, I send out a mass E-mail every 2-3 months to 3000+ users to check for Valid E-mail address’ with all the Unsubscribe stuff that’s required, I have it set to send about 600 An Hour, which was always good on my Paid host, So I was just thinking that all that just adds trust, Honestly if it isn’t a big deal, then I’ll not worry about it…

Guess it the word “Failed”, got me :sunglasses:

Oh and I fixed the bind issue, Restored Webmin Config from my Scheduled Back-ups, 1x at midnight EVERYNIGHT LOL… Knew the was I reason I set all that up 1st and the 5th clean install of the OS/Virtualmin/Forum…


Miker - you doing it in wrong way.

Not much help there unborn