Help with Migrating Wordpress blog


I am having some problems with wordpress migration.
I hope someone will be able to assist me, if not, I will understand.

So, I have moved DB, created Mysql user, copied zip file with content to public_html, unzipped files.
Wordpress works, I am able to log in and am able to look around.
Problem is with updating wordpress and updating plugins.
I googled and found that it’s a problem with permissions.

Now, I have assumed that If I upload files that they will get permissions of www group or user who is owner of virtual server. Perhaps that is the case but I may have screwed when I used webmin file manager to unzipped the content.

There are many articles about permissions and wordpress, some are even as strange to say to give all permissions to public_html.

I am a bit scared now, with shared hosting, I know it’s done in a secure manner, I hope that I wont accidentally screw permissions and make my blog insecure.

Have I made mistake when unzipping the content and applied wrong permissions by using webmin’s file manager?

How should I move the files to have right permissions for my blog?


On a Virtualmin system, it’s actually a bit easier to maintain permissions, since it doesn’t use mod_php.

Most articles you’ll read about WordPress assume that mod_php is being used, and the permissions required for that to work can be a bit more tricky.

On a Virtualmin system – you shouldn’t have to mess with file permissions or ownerships at all.

Virtualmin configures Apache to run PHP code as the Virtual Server account owner. So the key is just to make sure that the work you do with your blog is as the Virtual Server account owner, and not the root user.

If you log into Virtualmin as your Virtual Server owner, it should then be safe to use the Webmin file manager for manipulating your files and unzipping the archive you have.

However, the absolute worst case scenario – if users or permissions get mixed up – all you need to do is go into Limits and Validation -> Validate Virtual Servers -> Fix Permissions, and there you can reset the permissions of your files.

Oh, and if you haven’t already, we always recommend setting up backups, using Backup and Restore -> Scheduled Backups.


Hi Eric,

Thank you!

That worked. I am soooo impressed, looking at Virtualmin, I can see that it is really, a well engineered system.
Also thank you for your extensive and quick reply.

You saved me at least one night :slight_smile: