Help With Email Configuration

Hi This is my first post here and i have a problem i hope some of you can help me with.

my problem is as follows

I have a ubuntu server with virtualmin set up on it.

emails i sent from the first virtual server i set up which is also the system hostname send and are recieved fine, an example of the message header when sending from this domain is as follows.

x-store-info:4r51+eLowCe79NzwdU2kRwMf1FfZT+JrxVyutn/pLjrTdFvwilMo2/fnWaZaYVvQXpkXk+/lDLNQ9hpDAiXTpphsCAFZHhFUDw0XTLSMGSp/g8cYZvqmoOk3WDA03q/Ze8Pu1jHOFkI= Authentication-Results: hotmail.com; spf=pass (sender IP is 108.174.51.67) smtp.mailfrom=kas_1994@crazycomps.co.uk; dkim=pass (testing mode) header.d=crazycomps.co.uk; x-hmca=pass X-SID-PRA: kas_1994@crazycomps.co.uk X-AUTH-Result: PASS X-SID-Result: PASS X-Message-Status: n:n X-Message-Delivery: Vj0xLjE7dXM9MDtsPTA7YT0wO0Q9MjtHRD0yO1NDTD0w X-Message-Info: M98loaK0Lo2E/q9i63kwfgYw60xCFbkI6fTI7uWALLUpuI3alAQG3+UeOsPX0BDn2HwgpFsPLQSLt+2Q78ZSkfGbV69lRKKlkhfoxwQauwSuBuA0/P64ZX1xOgXYhrriZfTMFXzz/DYX41RhP/yyx2wKpruFwULI Received: from mail.crazycomps.co.uk ([108.174.51.67]) by BAY0-MC2-F43.Bay0.hotmail.com with Microsoft SMTPSVC(6.0.3790.4900); Thu, 7 Feb 2013 04:48:57 -0800 Received: from KylePC (5acb0bd4.bb.sky.com [90.203.11.212]) by mail.crazycomps.co.uk (Postfix) with ESMTPA id 4153AD90163A for ; Thu, 7 Feb 2013 16:48:56 +0400 (MSK) DKIM-Signature: v=1; a=rsa-sha256; c=simple/simple; d=crazycomps.co.uk; s=mail ; t=1360241336; bh=Rqt+QZIKSGrvm9LSqwPurS2ngFpuYsatAfIGZyzHA9I=; h=From:To:Subject:Date:Message-ID:MIME-Version:Content-Type; b=ffHd78CVUqFr+q+QfOkPhwlV7lwEwoJFx35CkNcVR8AZga5TEYU4ynKButkhH5eJE n59CX+d8Quwy+U7LDtu9v+8CmlvJMgpn4+koZGTjP1ZUx/3/I8HwepP8pJ6uie10U6 bD2McmHjOdZwTvMIFfiModdM3ZJdo4psiyXgJDJU= From: "Kyle Shackleton" To: Subject: crazycomps Date: Thu, 7 Feb 2013 12:48:55 -0000 Message-ID: <006801ce0531$7de81060$79b83120$@crazycomps.co.uk> MIME-Version: 1.0 Content-Type: multipart/alternative; boundary="----=_NextPart_000_0069_01CE0531.7DE81060" X-Mailer: Microsoft Outlook 15.0 Thread-Index: Ac4FMXrBhyB+G60eRZS8Tux1PI2qHA== Content-Language: en-gb Return-Path: kas_1994@crazycomps.co.uk X-OriginalArrivalTime: 07 Feb 2013 12:48:57.0198 (UTC) FILETIME=[7E5E78E0:01CE0531]

however when i send emails from any other virtual server domain set up on my system the emails are either not received by the recipitent or are sent to the spam/junk folders.

an example of a message header from one of my other virtual servers is shown below.

x-store-info:4r51+eLowCe79NzwdU2kRyU+pBy2R9QCr01wX+2TQb16V+IWYKH89OEXx2kXRCi0YCCbAc2czEzqYF2bH27mAPgHi3rzu7bpgBsHbtZAyLKnNk8fJmBxyu+VguRUNe13q5zZaaanxKw= Authentication-Results: hotmail.com; spf=temperror (sender IP is 108.174.51.67) smtp.mailfrom=teraqube@teraqube.com; dkim=temperror header.d=teraqube.com; x-hmca=none X-SID-PRA: teraqube@teraqube.com X-AUTH-Result: NONE X-SID-Result: NONE X-Message-Status: n:n X-Message-Delivery: Vj0xLjE7dXM9MDtsPTA7YT0wO0Q9MjtHRD0yO1NDTD02 X-Message-Info: M98loaK0Lo20GwCvHk/cR2X8Lyowyo79MC/TjfL1EJl4cdvAb3Dzl0RJtj56ZrHoUKREZeOz3xSpIeH0I8Agg87jg7mDdXqF7KOvCTW7SaRpYtlfHa+GnhNAPKL6rvMh82W76iku2JvcnUnuLUh2oyNi/WQIkCfU Received: from mail.crazycomps.co.uk ([108.174.51.67]) by SNT0-MC1-F5.Snt0.hotmail.com with Microsoft SMTPSVC(6.0.3790.4900); Thu, 7 Feb 2013 04:47:20 -0800 Received: from www.crazycomps.co.uk (localhost.localdomain [127.0.0.1]) by mail.crazycomps.co.uk (Postfix) with SMTP id E7B44D90163A for ; Thu, 7 Feb 2013 16:47:19 +0400 (MSK) DKIM-Signature: v=1; a=rsa-sha256; c=simple/simple; d=teraqube.com; s=mail ; t=1360241240; bh=D/wd+JYwIyR9WNLHdolz437Br1DFOkiuN0sX9I4/vIY=; h=From:Subject:To:Message-Id:Date:MIME-Version:Content-Type; b=Kqc4FVXoubYuyjL81C6hqvYFruooy3OqIJPq6RfFSQCMGtMfmp4SDwSCebqX+oQYT Hr1sI8n1P+0RCFJW8Ms+JNcitZ9MaDH0lDhyI9wh8yV8VSwQ5OLYgCcbhfnslZ9t0Z 2MSU2x/JnRhkDaNjokkuTnuxL6poGSmXULpny2BU= From: teraqube@teraqube.com Subject: newtest To: kyleshack@msn.com Message-Id: <1360241239.17529@teraqube.com> X-Originating-IP: 90.203.11.212 X-Mailer: Usermin 1.520 Date: Thu, 07 Feb 2013 16:47:19 +0400 (MSK) MIME-Version: 1.0 Content-Type: multipart/mixed; boundary="bound1360241239" Return-Path: teraqube@teraqube.com X-OriginalArrivalTime: 07 Feb 2013 12:47:20.0536 (UTC) FILETIME=[44C10580:01CE0531]

As You can see i get temperrors on both my Spf and DKIM records and i am hoping that someone can point me in the right direction to fix this problem

Also note that i dont mind configuring settings outside of virtualmin to get this to work correctly as long as it does not effect my other systems on virtualmin

Many thanks in advance for your help

Kind Regards

Kyle Shackleton

Bump

Hi Kyle,

If this is still not working, please post a current header from teraqube.com

I see both spf and dkim are published, but didn’t attempt to verify them.

Hello,

I got the same issues, do you have any answer regarding the solution ?

Thank You !