Help with Email - ClamAV - Spamassasin

Hi!

I´m new to this forum. I´ve redently got a dedicated server and installes Centos 7 with Virtualmin to server a few WEbsites that I have.

Install was pretty easy and now I can say that I have Virtualmin near production, so I can migrate all sites.

But I have a problema with my mails:

  1. ClamAV had trouble and I found some solutions in this forum that a I´ve aplied.

ClamAV is running:

[root@srv1 mail]# systemctl status clamd@scan
● clamd@scan.service - Generic clamav scanner daemon
Loaded: loaded (/usr/lib/systemd/system/clamd@scan.service; enabled; vendor preset: disabled)
Active: active (running) since Di 2016-11-29 18:14:39 BRST; 32min ago
Main PID: 2639 (clamd)
CGroup: /system.slice/system-clamd.slice/clamd@scan.service
└─2639 /usr/sbin/clamd -c /etc/clamd.d/scan.conf --foreground=yes

Nov 29 18:14:46 srv1.loewenhaupt.com.br clamd[2639]: HTML support enabled.
Nov 29 18:14:46 srv1.loewenhaupt.com.br clamd[2639]: XMLDOCS support enabled.
Nov 29 18:14:46 srv1.loewenhaupt.com.br clamd[2639]: HWP3 support enabled.
Nov 29 18:14:46 srv1.loewenhaupt.com.br clamd[2639]: Self checking every 600 seconds.
Nov 29 18:24:46 srv1.loewenhaupt.com.br clamd[2639]: SelfCheck: Database status OK.
Nov 29 18:24:46 srv1.loewenhaupt.com.br clamd[2639]: SelfCheck: Database status OK.
Nov 29 18:34:46 srv1.loewenhaupt.com.br clamd[2639]: SelfCheck: Database status OK.
Nov 29 18:34:46 srv1.loewenhaupt.com.br clamd[2639]: SelfCheck: Database status OK.
Nov 29 18:44:46 srv1.loewenhaupt.com.br clamd[2639]: SelfCheck: Database status OK.
Nov 29 18:44:46 srv1.loewenhaupt.com.br clamd[2639]: SelfCheck: Database status OK.

But the procmail.log give me this error msgs:

From securitycheck@emailsecuritycheck.net Tue Nov 29 18:37:48 2016
Subject: Test mail 2/7 (ID=xcWmslfdgxRiGJljrfuw==)
Folder: /home/loewe/Maildir/new/1480451871.4005_0.srv1.loewenhaupt.c 2136
Time:1480451871 From:securitycheck@emailsecuritycheck.net To:loewe@loewenhaupt.com.br User:loewe Size:2204 Dest:/home/loewe/Maildir/new/1480451871.4005_0.srv1.loewenhaupt.com.br Mode:None
ERROR: Could not lookup : Servname not supported for ai_socktype
ERROR: Could not lookup : Servname not supported for ai_socktype
procmail: Unable to treat as directory “/home/loewe/~/Maildir/.spam”
procmail: Error while writing to “/home/loewe/~/Maildir/.spam”

I have setup virtualmin to send all identified SPAM mail to the Spam folder… But as you can see, there is an error :frowning:

Can anyoone helo me with this two erros msgs?

Regards

Mario