Help: virtualmin, nginx, timthumb and gd library

Sort of at the end of my rope here; I must be missing something but have been trying to take the necessary steps.

I’ve apt-get install php5-gd. I’ve made sure that it’s installed as outlined here:

ie if I
php5 -m | grep -i gd I get ‘gd’ as a response, so php sees it. I also see how it’s been added to the /var/php5/conf.d and being picked up.

I’ve restarted the php5-fpm service as well as restarted nginx

I’ve made sure that the original timthumb script was allowed to execute by anybody (yeah, testing everything); I’ve made sure the cache folder had permissions etc etc.

And yet if I try to hit an image I get:

A TimThumb error has occured

The following error(s) occured:
GD Library Error: imagecreatetruecolor does not exist - please contact your webhost and ask them to install the GD library


What you may want to try is to create a script called “test.php”, and in it, create the following code:

<?php phpinfo(); ?>

Then, browse to that, and verify that it’s not loading the GD library.

If it isn’t, check which php.ini file it’s using, as it may be using a different one than the one you had edited.


Hey Eric -

Thanks for the response; I finally rebooted the server and everything ‘took’; so perhaps it was some init process I had missed.

Again, I appreciate the response. I’m going to start a new forum topic about not being able to SEND email from a client though I can receive (client settings perhaps though I’m trying on multiple computers / multiple domains) so feel free to drop some knowledge there as well :stuck_out_tongue:

Just going to trawl through the forums first to see if it’s been asked before…