*help* I need to update my bind via shell

Hi guys, I am assuming that I have done something silly, actually I know what I did and assume the problem I am now having is a direct result.

To cut a long story short I deleted a virtual server off virtualmin that was linked to the nameserver and BIND and now I cannot access virtualmin via IP address or URL. I can, however still get to a handful of domains via URL so the issue I believe is just a simple configuration error.

What I need to do is go into the DNS settings for each domain via SSH, for the life of me (probably the time and an 18 hour day already) I am having a brain fart and can’t recall which file I need to open to do so.

The DNS lookup is saying that the domains I cannot find any nameservers, my guess is that when I first setup the server I used pixel.webhostsheffield.com, ns1.webhostsheffield.com and ns2.webhostsheffield.com but later on decided to have webhostsheffield.com as a virtual server and played around with the DNS to ensure it all worked, now I have removed the webhostsheffield virtual server it appears I removed the nameserver details and did not put the pixel.webhostsheffield.com record back. (the virtual server was actually redundant anyway)

I cannot access the virtualmin backend using IP address either, if I do this it opens one of my client domains up.

In any case, I think this is all that is needed, it is odd how some of the sites are up and functional, others are having lookup errors but if any of you are around and can gently remind me of which file(s) I need to pop open in nano I would greatly appreciate it.


I cannot access virtualmin via IP address or URL

Hmm… something about that sounds odd. Even if you completely delete BIND from your server, Virtualmin should continue to be accessible via IP address. Accessing services via an IP address doesn’t perform a DNS lookup, and wouldn’t require BIND.

Are you sure that’s not working though? I went to the IP address that appears to be associated with your server, and was able to access a Virtualmin login screen.

You should be able to access Virtualmin using this URL:


(where x.x.x.x is either of your two public IP addresses)

What I need to do is go into the DNS settings for each domain via SSH, for the life of me

Hmm, if you ran into problems by removing just one domain, it shouldn’t be necessary to make changes to BIND for each domain on your server.

When I look up your DNS information for the domain name you shared above, it showed a few errors – including one that made it appear that BIND may not actually be running.

You may want to make sure your BIND service is running and remotely accessible before making any changes.

You can use the site intodns.com in order to perform DNS tests.


Hi Eric, it is definitely due to the removal of the nameserver records but I am just not sure what file i am supposed to add them back into for the master domain (webhostsheffield.com)

Slowly, as the DNS propagates the domains that were working are not connecting with the same issues. As you say the IP address will now allow me to get access to the control panel when I put my brain in and remember the https:// so where do I go from here?

I need to make sure that there is a record for pixel.webhostsheffield.com under the server root or master and also the ensure that ns1 and ns2.webhostsheffield are actually there.

Just as a quick update. I have slapped a band-aid over it for now by simply creating the webhostsheffield.com virtual server and all the domains are now working again, clearly this is not 100% correct though so I would still like to check over the main server DNS settings to be sure they are set correctly - realistically I can easily get away with leaving the domain in place though if it makes things work