Help for Cloudmin PRO and Debian Squeeze "command hvmloader was not found"

Hi, with cloudmin pro and debian squeeze I’m unable to create a new virtual machine, this is the error:

Creating virtual system with Xen …
… creation failed : The Xen HVM loader command hvmloader was not found on $1

But on my debian hvmloader is available:

root@server:~# locate hvmloader
/usr/lib/xen-4.0/boot/hvmloader

and Xen is running:

root@server:~# xm list
Name ID Mem VCPUs State Time(s)
Domain-0 0 7865 2 r----- 1968.5

How can I fix it? With the same installation on CentOS 5 all works fine. My cloudmin version is 5.5

Thanks

Howdy,

I’m not quite sure, but Jamie would know what’s going on there :slight_smile:

My suggestion is to file a support request using the Support link above, and Jamie will be able to work with you and figure out what’s going on there.

-Eric

Hi, solved with:

mkdir /usr/lib/xen/boot
ln -s /usr/lib/xen-4.0/boot/hvmloader /usr/lib/xen/boot/hvmloader

but I have found some other issue during the installation, for example with:

IP address for Xen instance Assign automatically

get this error:

Failed to create system : Failed to allocate an IP address on scbs-mx130.cbsolt.net from the range

Thanks

For me, under Debian 6.0, Cloudmin was looking in /usr/lib/xen instead of /usr/lib/xen-4.0. This fixed it…

cd /usr/lib/ && ln -s xen-4.0 xen

Can the CloudMin devs perhaps add an option in the CloudMin code to automatically look for the hvmloader file in the correct place when using Debian sqeeze + XEN 4?