HELP, domains not resolving

Hello
I have installed WebMin and Virtualmin, I have created virtual servers, the BIND server is up and running without errors, I have the following DNS records
$ttl 38400
@ IN SOA ns1.webmarketersclub.com. root.ns1.webmarketersclub.com. (
1332001831
10800
3600
604800
38400 )
@ IN NS ns1.webmarketersclub.com.
webmarketersclub.com. IN NS ns2.webmarketersclub.com.
webmarketersclub.com. IN A 92.48.84.211
www.webmarketersclub.com. IN A 92.48.84.211
ftp.webmarketersclub.com. IN A 92.48.84.211
m.webmarketersclub.com. IN A 92.48.84.211
ns1.webmarketersclub.com. IN A 92.48.84.211
ns2.webmarketersclub.com. IN A 94.76.192.48
localhost.webmarketersclub.com. IN A 127.0.0.1
webmail.webmarketersclub.com. IN A 92.48.84.211
admin.webmarketersclub.com. IN A 92.48.84.211
webmarketersclub.com. IN TXT “v=spf1 a mx a:webmarketersclub.com ip4:92.48.84.211 ?all”

but the domain is not resolving I don’t know what I am missing?

Any help will be GREATLY appreciated

Howdy,

It looks like the nameservers for your domain are pointed to your registrar.

That’s okay, but that means you would need to manually setup your DNS records at your registrar.

If you’d like to use your own server as a nameserver, there’s some details on that here in the section named “How do I setup nameservers for my server”:

http://www.virtualmin.com/documentation/dns/faq

Hello and thank you for your comment, however the current setup is what I switched to after failing to use my own server as a nameserver. I did follow those steps, assigned IP’s to the NS records, as you can see from the data I originally pasted above, edited template as per attachment (well seems attaching a file keeps timing out on me so no attachment) , but still it would not resolve, so I am wondering what could I possibly have done wrong?

Marco

Well, it’s difficult to say why your previous setup didn’t work; and if you wanted to point your nameservers back to your Virtualmin server, we can certainly run some diagnostics and see if we can figure out what’s awry.

However, what I can offer is that, with the setup you have now – your domain’s nameservers are pointing to your registrar, and your DNS records aren’t setup there.

So if you wish to use your registrar as your nameserver, no problem, but you’d need to setup your records there.

If instead you wish to use your Virtualmin server, you’re welcome to change your nameservers to point there, and we can do some troubleshooting to try and figure out why it’s not working for you.

-Eric

In addition to what Eric correctly said:

The authoritative nameservers for webmarketersclub.com indeed are configured to be dns1.registrar-servers.com thru dns5.... For me though, the domain (and subdomain www.) correctly resolves to the IP address you mentioned, as returned by all 5 authoritative servers.

Maybe a recently performed zone change needed time to propagate.

Thanks all for your help

The point is that the NS may appear to resolve and point correctly, however when I create a new virtual server and try to use those NS records, the new domain won’t resolve. Propagation should not be an issue as those domains have been using the very same DNS and very same IP on the very same machine for about 2 years, except I now decided to switch from CPanel to Virtualmin/Webmin and all at a sudden I am facing all those problems.

@andreychek , I have no problem in switching back the NS servers and have them point to the Virtualmin server to test, just let me know when would be a good time for you , as to reduce downtime

If acceptable I can even PM you the credentials?

Marco

Check for example www.overfifty.co.uk it is correctly showing ns1.webmarketersclub.com and ns2.webmarketersclub.com as the assigned NS , it is showing the below in Virtualmin Server Configuration->DNS Records
$ttl Default Cache Time 38400
overfifty.co.uk SOA - Start Of Domain ns1.webmarketersclub.com. root.ns1.webmarketersclub.com. 1332066455 10800 3 …
overfifty.co.uk NS - Name Server ns1.webmarketersclub.com.
overfifty.co.uk NS - Name Server ns2.webmarketersclub.com.
overfifty.co.uk A - IPv4 Address 92.48.84.211
www A - IPv4 Address 92.48.84.211
ftp A - IPv4 Address 92.48.84.211
m A - IPv4 Address 92.48.84.211
localhost A - IPv4 Address 127.0.0.1
webmail A - IPv4 Address 92.48.84.211
admin A - IPv4 Address 92.48.84.211
overfifty.co.uk SPF - Sender Permitted From v=spf1 a mx a:overfifty.co.uk ip4:92.48.84.211 ?all

I ran the validate virtual servers tool for BIND DNS domain on Virtualmin and no errors were returned

I am really at a loss here, I am sure it is something silly but it seems the only option I have is to uninstall and start form scratch?

Why uninstall and restart from scratch? This is not how Linux works…on windows machines that would likely be applicable but not with Linux.
Linux is great because you can change some settings and then it will do as you expect.

Look
http://www.intodns.com/overfifty.co.uk
If you have no A records for your nameservers then you will have problems. So start with adding those.
If you do have A records, it might happen that your nameservers cant respond due to a setting in the BIND module.
You will have to overlook those settings and correct them until your nameservers will respond to outside queries.

Thanks ronald, however I DO have glue records created for both ns1.webmarketersclub.com and ns2.webmarketersclub.com (I have had then since early 2010 and nothing changed since then…) and I have assigned an IP address to each one of them (same as the glue record of course :wink: ) , but it seems they are not responding, so I think that , as you say there is some setting in the BIND module but that is eaxctly where my problem lies… WHAT exactly should I look for?

so in webmin-servers-bind dns server look into “Miscellaneous Options” and set Do full recursive lookups for clients? to Yes. Also set “Fetch glue records?” to default or to yes
Then under “Addresses and Topology” set “Allow recursive queries from” to listed and then list in the box below: localhost and 127.0.0.1
127.0.0.1 must be listed as a nameserver in the Webmin - networking - Network configuration - Hostname and DNS Client
Then restart BIND

after retsrting BIND:
IF this is by any chance Centos 6, look inside the /etc/named.conf and see to it that it looks like below.
Important is the recursion yes and fetch-glue to yes under the options section…

[code]options {
listen-on port 53 {
any;
};
listen-on-v6 port 53 {
any;
};
directory “/var/named”;
dump-file “/var/named/data/cache_dump.db”;
statistics-file “/var/named/data/named_stats.txt”;
memstatistics-file “/var/named/data/named_mem_stats.txt”;
recursion yes;

dnssec-enable yes;
dnssec-validation yes;
dnssec-lookaside auto;

/* Path to ISC DLV key */
bindkeys-file "/etc/named.iscdlv.key";
fetch-glue yes;

};
[/code]

Ok, I have done that and yes I have CenOS 6 and the only difference with the lines you posted seems to be the following:

/* Path to ISC DLV key */
bindkeys-file “/etc/named.iscdlv.key”;
fetch-glue yes;
allow-recursion {
localhost;
127.0.0.1;
};

Does it make any difference?

Thanks again for all your help!

that seems right. Centos 6 is doing things a little bit different than previous editions.
Your nameservers still do not respond at this moment. I remember I had the same troubles when I started with Centos 6.

In the /etc/named.conf have your IP’s listed

options {
   listen-on port 53 {
        127.0.0.1;
     94.76.192.48;
     92.48.84.211;
      };

Look in the webmin-networking-network configuration- host addresses and that you have entries there
94.76.192.48 ns2.webmarketersclub.com , ns2
92.48.84.211 ns1.webmarketersclub.com , ns1

Allright, I have edited the /etc/named.conf as per your suggestion however I am not sure how to create the entries you suggested in webmin-networking-network configuration- host addresses ?

I enter 92.48.84.211 in the IP address box, then in the hostnames I type ns1.webmarketersclub.com , ns1 on one line but get an error message
‘,’ is not a valid hostname

?

Figured the part about adding hostnames, let’s see what happens now, still not resolving

Here is a thread that I contributed to. centos 6 and bind
http://www.virtualmin.com/node/20420

per haps it mentions some steps that you will need to do still…

Thanks, I actually already have the situation suggested in post15 in that thread: http://www.virtualmin.com/node/20420#comment-96420
I had previosuly changed the Chroot directory to run BIND under from whatever it was there to / , however I have now modified it to ‘None’ as per your suggestion and edited the location of named.conf although from what I can see it was already the right file /etc/named.conf that was being used and edited

Now let’s see what happens…

ronald maybe I could create and amin login for you if you would be so kind? possibly it is something encredibly easy and silly for somebody who knows where to look?

Thx a million again

I just ran this check and it seems there is definitively something wrong with the NS setup? NS not responding?

http://www.intodns.com/webmarketersclub.com

Well, I have been trying all possible combinations, reading forums, searching Google and then more yet my domains are note resolving, it looks like after all I may be better off spending money on Cpanel, I just wasted 2 days trying tofix something that is a basic essential function, so I am worried about what woudl happen with more sophisticated needs/requests.

Thanks ronald for all your help, but it looks like I am not the right person for Virtualmin, I am looking for something that would ‘work’ not force me to spend 2 days ‘researching’ it

I dont think this is a virtualmin issue.
Centos 6 has some differences to previous editions that made me also dive into it deeper then I wanted.

If you want I can have a look and compare it to my Centos 6 installation. Once its running you will be glad you’d switch from cpanel to virtualmin.

Some stuff could be as easy as a firewall blocking port 53
anyway you can email me if you want at helpdesk @ stichtingizi . nl

I can probably look at it tomorrow evening as I am in transit at the moment and flying home tomorrow afternoon

this afternoon the error was: query timed out
this is no longer the case
now it gives the refused code which is 1 step forwards

50.0% of queries will end in failure at 92.48.84.211 (ns1.webmarketersclub.com) - returned REFUSED code
50.0% of queries will end in failure at 94.76.192.48 (ns2.webmarketersclub.com) - returned REFUSED code

it means there is one little step to take but I dont know this setting by heart.