HELP ASAP

Hello,

I have set up coolstack and Virtualmin , i am getting following error,

The Suexec command on your system is configured to only run scripts under /opt/coolstack/apache2/htdocs, but the Virtualmin base directory is /home. CGI and PHP scripts run as domain owners will not be executed.

Pls help

I’m not sure what coolstack is, but it’s sounding like you’re running Virtualmin on an OS or distro that wasn’t supported by the installer. You can see the list of supported OS’s and distros here:

http://www.virtualmin.com/os-support

The issue is that suexec will only work if it’s compiled to run under /home, rather than “/opt/coolstack/apache2/htdocs”.

Your options are:

  1. Disable suexec in the Server Templates (in System Settings -> Server Templates -> Apache Website)

  2. Recompile suexec to work under /home

  3. Install Virtualmin using another OS/distro, and the installer would make sure you have a working suexec version (the Virtualmin software repository has versions compiled for supported platforms)

-Eric

yes, It was Solaris 10 and Coolstack , I am using virtualmin long years, But they allowed me to create virtual server with it and any any home dir. with coolstack.

can you help me pls how to set up Apache directive? i forgot that :slight_smile:

You’ll need to disable the suexec option… it’s in System Settings -> Server Templates -> Apache Website, named “Automatically add appropriate SuExec directive”.

-Eric

If i disable it then the new users will dir will not public_html right? what’s the other way ? pls help