Help a newbie with Nginx

Good morning, sorry for not responding yesterday, I did the tests and now I am getting DNS errors on the domains. So what I did was removed all the A Records on BlueHost and started fresh, so far this is how the domain is configured in BlueHost.

ns1,domain,com - PublicIP
ns2,domain,com - PublicIP

The second one is just domain,com

Should I add anything else to the records?
Also, since we’ve gone beyond Nginx and you said all that is done by Virtualmin automatically. I decided to start fresh, deleted the VM, I am recreating it on Ubuntu Live Server 20.04, and this time I will install with Apache.

Good idea to start fresh.

So for domain.tld, the nameserver at BlueHost will handle the records (which you will set manually) so domain.tld will point to BlueHost nameservers

For clientdomain.tld the nameserver at Virtualmin will handle the records (automatically) so clientdomain.tld will point to ns1.domain.tld and ns2.domain.tld.

At a later stage, you can learn about glue records and configure domain.tld to point to ns1.domain.tld and ns2.domain.tld. Do not attempt to point domain.tld to ns1.domain.tld and ns2.domain.tld till you have had the glue records configured.

Oh, so I need to revert the ns1 and ns2 back to the BlueHost default ones, and then only set the DNS records for the other domains that I want to manage to ns1,mydomain,com and ns2,mydomain,com. Go it, I will revert that right now, and then I will run the new Virtualmin install, I will let you know when that’s done to see where we stand. Thank you!

Good morning @calport, so I have rebuilt the webserver, and changed all the A Records, now all 3 URLs, www,domain,com, webhost,domain,com and admin,domain,com redirect to the Virtualmin Under Construction page. What do I do now?

A very good morning to you, @Misinthe.

I assume you have completed the post install wizard and set up a virtual server (via Virtualmin → Create Virtual Server) for domain.tld and perhaps one more virtual server for a test clientdomain.tld?

Right now all I’ve done is gone through the post install wizard, set up the Virtual server for webhost,domain,com which is the main host. Should I create a second one for my www,domain,com? And now we’re to the stage of what I was asking at first, to get to Virtualmin, I have to type in https;//webhost,domain,com:10000, how do I make it where I can just type webhost,domain,com and it will send me to the log in page?

I tried to create a new Virtual Server with my domain, I got the next error with Let’s Encrypt.
Any idea what it could be?

What I have done here works quite well in terms of offering my users a login page:

To explain a bit in detail:

You could do the same on your system. Your webhost.domain.tld could be what my is and your www.domain.tld could be your own (or your business) website.

You would not have got this error if:

  • ns1.domain.tld and ns2.domain.tld point to the IP address of your Virtualmin server and you have manually set up these to do so within the BlueHost control panel

  • ns1.domain.tld and ns2.domain.tld have been specified as nameservers in Virtualmin post install wizard

I think you probably have got both these done already. If not please do so, test for propagation and then try to request a SSL for domain.tld from Let’s Encrypt again via Virtualmin → Server Configuration → SSL Certificate

Good morning, I’m a little lost when you’re talking about the DNS settings. You’re saying to put in ns1,domain,tld and ns2,domain,tld in the BlueHost DNS settings. But earlier you said to leave the BlueHost DNS set to BlueHost, because it wouldn’t resolve?

Right now the DNS settings on BlueHost are like this.

And what I did was add A Records for ns1 and ns2 pointing to my Public IP. Is that what I should’ve done?

@calport I am happy to announce that I have got it working! I understand what you mean now with the DNS. I will do what you sugested and just created a redirect website for the log in page. There should be a way where we can redirect the subdomain to a port on Apache, I will dig that a bit more. Also, I don’t know why, but I have the SSL Certificate from Let’s Encrypt on the webhost,domain,com but I still keep getting this error, but it works on the main domain.


This topic was automatically closed 8 days after the last reply. New replies are no longer allowed.