Having trouble installing a subversion repository

I am having some issues getting a subversion repository to install…this is what has happened so far…

I set up a domain in Virtualmin then enabled SVN. I go to the “Virtualmin Subversion Reponsitory” in webmin and then enter the name for a new repository. using the following:

repository name: test
Under server: testserver.com
Repository Type: Versioned Filesystem (FSFS)
Allow anonymous read access: No

Then I press create and get this:

Failed to create repository :
svnadmin: Repository creation failed
svnadmin: Could not create top-level directory
svnadmin: Can’t create directory ‘/home/virtual/testserver.com/svn/test’: No such file or directory

When I look in my folders, there is no svn folder at /home/virtual/testserver.com. testserver.com is chmod’d as 777 and I tried owning it by the user as well as by apache and it won’t greate the svn folder. Inside that testserver.com folder I have:


So, I went ahead and created the SNV folder. Then I went back and tried to create the repository again…and then I get:

Failed to create repository : Failed to open /home/virtual/testserver.com/etc/svn-access.conf.webmintmp.19306 : No such file or directory

But, there are now files in the repository and it is also showing up under the “Virtualmin Subversion Repositories”. So, I think everything is good…right? Wrong.

I next go to Virtualmin, select the domain and then “Edit FTP Users” and filter down to “other user permissions”. I enable subversion login, add the repository to the “Allowed Repos” under read/write access, and then press save and get:

Failed to save mailbox : Failed to open /home/virtual/testserver.com/etc/svn.basic.passwd for writing : Bad file descriptor at …/web-lib-funcs.pl line 1360.

I am assuming there are bad permissions somewhere along the line that are making this break but I don’t know where this is happening…any ideas?