Having problem to sign in to SSH

Dear all,

I have problem signing in to one of the servers using SSH. It happened after I changed the root password using Webmin. I have google to find a solution but haven’t been able to solve the problem. I had been using password method to sign in to the server.

Could anybody, please, help me to troubleshoot the problem and solve it?

Thanks in advance!


Are you still able to login via Webmin as root?

Also, when trying to login via SSH, did you try both the old and the new password?


Hello, Andreychek.

I am able to login via Webmin. I have tried changing password a few times and it all works with Webmin but the SSH.

I didn’t try the old password as I don’t have it anymore. Moreover, I didn’t think of it as I consciously knew that changing root password via Webmin changes the SSH root password as well.

I have also restarted SSH via Webmin thinking that it might help to solve the problem but no success.


Can you describe what process you using to change the password within Webmin?


Hi, Eric.

I go to Webmin from top and then I choose Webmin Users under Webmin menu. From there I choose root user and change password.

Now I will google to see if there is another way to change the password and will try to see if that solves the problem.


Aha, that would just change the Webmin password.

For changing a password, my suggestion would be to go into Webmin -> System -> Change Password. That will change the system password, and not just the Webmin password.


Hi, Eric!

I’m so grateful for the hint! Changing password as you suggested solved the problem! I couldn’t find a solution to the problem googling it.

Thank you so much for your time and for your help!