Greylistning not working / running


I have some trouble with getting greylisting to work. First I enabled greylisting from virtualmin but no emails got delivered.

Mar 24 22:00:17 [SERVER_HOSTNAME] postfix/smtpd[25943]: warning: connect to Connection timed out
Mar 24 22:00:17 [SERVER_HOSTNAME] postfix/smtpd[25943]: warning: problem talking to server Connection timed out
Mar 24 22:00:17 [SERVER_HOSTNAME] postfix/smtpd[25943]: NOQUEUE: reject: RCPT from unknown[REMOTE_SERVER_PUBLIC_IP]: 451 4.3.5 Server configuration problem; proto=ESMTP helo=<>

I found some threads in this forum suggesting the following change:




But this didn’t work so I figured I’d disable the greylisting for the moment but I think something messed up the postfix configuration.

Mar 24 23:40:48 [SERVER_HOSTNAME] postfix/smtpd[2057]: connect from [RDNS][REMOTE_IP]
Mar 24 23:40:48 [SERVER_HOSTNAME] postfix/smtpd[2057]: warning: restriction check_policy_service must be followed by transport:server
Mar 24 23:40:48 [SERVER_HOSTNAME] postfix/smtpd[2057]: NOQUEUE: reject: RCPT from [RDNS][SENDER IP]: 451 4.3.5 Server configuration error; proto=ESMTP helo=<>

So I once again found the solution in this forum

Removed: check_policy_service

Now, I would like to get greylisting to work, I know it worked for half a day since I could send and recive emails and have this log:

Mar 24 14:32:12 [SERVER_HOSTNAME] postgrey[545]: action=pass, reason=triplet found, client_name=RDNS, client_address=[SENDER_IP],,

  • Ubuntu 14.04 LTS
  • Latest Webmin / Virtualmin
  • Only running ipv4 so maybe this is the issue ?
  • Running iptables in Webmin with default action drop and all web and mail ports opened (80, 443, 25, 143 etc etc)

Any ideas how to solve this?


Well, let’s start here and make sure that Postgrey is running… what is the output of this command:

netstat -an | grep :10023

Hi andreychek,

Yesterday I ran the postgrey status command and it returned “not running”.

Let me just enable greylisting again and run the netstat command.

Here is the command from netstat -an | grep :10023

tcp 0 0* LISTEN

I’ve also tried to send an email from my Zimbra installation, it got greylisted so waiting for Zimbra to send the email again. But it seems to be working now. Let me just evaluate a little bit more.

Mar 25 09:43:03 [SERVER_HOSTNAME] postfix/smtpd[1715]: connect from[]
Mar 25 09:43:03 [SERVER_HOSTNAME] postgrey[1487]: action=greylist, reason=early-retry (122s missing),, client_address=,,
Mar 25 09:43:03 [SERVER_HOSTNAME] postfix/smtpd[1715]: NOQUEUE: reject: RCPT from[]: 450 4.2.0 Recipient address rejected: Greylisted, see; proto=ESMTP helo=<>
Mar 25 09:43:03 euve112262 postfix/smtpd[1715]: disconnect from[]

Seems to be working now, don’t know what happend yesterday. I also tried to restart the server to be 100% sure but it’s still working.

I notice one thing that happend yesterday, I was updating my DNS servers to google DNS from (Webmin < Networking < Network configuration) and my hostname got messed up on save.

Before save: Hostname:
After save: Hostname: server

of course I changed the hostname back but maybe this was the cause ?


Hmm, it’s hard to say, but I’m glad to hear it’s working for you now!


postgrey has been a nightmare on Ubuntu+Virtualmin. Always crashing.
I ended up using gld from and never had a problem.