gpg: WARNING: using insecure memory!

Hi,

I keep getting the following error generated by scriptlatest.pl

gpg: WARNING: using insecure memory!
gpg: please see http://www.gnupg.org/faq.html for more information

Any ideas?

Thanks, Martin

Howdy,

Hmm, are you by chance using a VPS?

Reading the GPG docs, it sounds like that problem shouldn’t occur, except in rare situations that are memory related… and certain VPS’s could end up triggering that particular problem.

-Eric

Hi Eric,

Yes, it’s a Centos 5.8 VPS running Virtualmin 3.94 GPL on OpenVZ.

I’m currently running the Virtualmin updates for Webmin to 1.600-1 and Usermin to 1.520-1.

Thanks, Martin

Howdy,

Yeah, on an OpenVZ-based VPS – chances are there’s nothing you’ll be able to do about that particular message. It’s likely related to the way your resources are setup.

You could always edit the cron job where scriptlatest.pl is being run, and you could pipe all it’s output into /dev/null… that would prevent the warning from being emailed to you each day.

-Eric