Google API will not load into virtualmin

| OS type and version | Debian Linux 11 |
| Webmin version | 2.021 |
| Virtualmin version | 7.7pro |
| Related packages | composer require google/apiclient:^2.0 |

I am so lost :frowning: and i don’t want to try to many crazy things but internet keeps leading me to this command ‘composer require google/apiclient:^2.0’ and it worked after i put in composer but i still can’t call on the API im coding in php and i call on it with “require_once ‘vendor/autoload.php’;” but it’s like NOPE

Fatal error : require_once(): Failed opening required ‘vendor/autoload.php’ (include_path=‘.:/usr/share/php’)

i’m worried it’s super easy and i’m just stupid.

This is not a virtualmin issue but a php issue … your code can not find ‘vendor/autoload.php’ are you sure you path to the file is correct ?
if the vendor directory is below the directory you code in it should work, if not you will have to put the full path to the file like

require_once ‘/home/bill/someproject/vendor/autoload.php’

1 Like

Yip, i tried many many combinations. i think im going to download and just put the entire google api into the public_html folder and call it from there / use / include

i am a broken man, i give up. i am just going to get it create a “add to calendar link”. no api needed