Git repositories module- how to configure?

I have the Git Repos module set up successfully, but when I check the box under Features and Plugins and click save, I get an error: “Failed to save enabled features : The plugin Git repositories cannot be used : The Git administration command git is not installed”

Under Configure > Full path to git command, the default entry is “git”. This apparently needs to be changed, but I’m unclear as to what should be entered in this field. A Google search yielded nothing on this. Can anyone help?

Thanks!

Jack

i recommend you run “updatedb”. After run “locate git”. It should tell you where the binary is located at.

Howdy,

Also, if git’s not installed, you may just need to install that package. You can do that with “apt-get install git” or “yum install git”, depending on your distro.

-Eric

Thanks, below is the output from “locate git”. I also ran “which git” which shows that it’s not installed.
I’m running Centos 5.8. I’ve run “yum install git” which appears to be successful, but I must be missing something (I’m new to linux). That output is also below.

locate git
/etc/webmin/virtualmin-git
/etc/webmin/virtualmin-git/config
/usr/lib/perl5/5.8.8/unicore/To/Digit.pl
/usr/lib/perl5/5.8.8/unicore/lib/gc_sc/Digit.pl
/usr/lib/perl5/5.8.8/unicore/lib/gc_sc/HexDigit.pl
/usr/lib/perl5/5.8.8/unicore/lib/gc_sc/XDigit.pl
/usr/lib64/python2.4/cgitb.py
/usr/lib64/python2.4/cgitb.pyc
/usr/lib64/python2.4/cgitb.pyo
/usr/libexec/webmin/virtualmin-git
/usr/libexec/webmin/virtualmin-git/add.cgi
/usr/libexec/webmin/virtualmin-git/config
/usr/libexec/webmin/virtualmin-git/config.info
/usr/libexec/webmin/virtualmin-git/delete.cgi
/usr/libexec/webmin/virtualmin-git/git-favicon.png
/usr/libexec/webmin/virtualmin-git/git-logo.png
/usr/libexec/webmin/virtualmin-git/gitweb.cgi.source
/usr/libexec/webmin/virtualmin-git/gitweb.cgi.source.new
/usr/libexec/webmin/virtualmin-git/gitweb.css
/usr/libexec/webmin/virtualmin-git/help
/usr/libexec/webmin/virtualmin-git/help.cgi
/usr/libexec/webmin/virtualmin-git/images
/usr/libexec/webmin/virtualmin-git/index.cgi
/usr/libexec/webmin/virtualmin-git/lang
/usr/libexec/webmin/virtualmin-git/log_parser.pl
/usr/libexec/webmin/virtualmin-git/module.info
/usr/libexec/webmin/virtualmin-git/postinstall.pl
/usr/libexec/webmin/virtualmin-git/virtual_feature.pl
/usr/libexec/webmin/virtualmin-git/virtualmin-git-lib.pl
/usr/libexec/webmin/virtualmin-git/help/git.html
/usr/libexec/webmin/virtualmin-git/help/label.html
/usr/libexec/webmin/virtualmin-git/help/reps.html
/usr/libexec/webmin/virtualmin-git/lang/en
/usr/share/awstats/wwwroot/icon/cpu/digital.png
/usr/share/awstats/wwwroot/icon/os/digital.png
/usr/share/doc/rsync-3.0.6/support/git-set-file-times
/usr/share/man/man3/isdigit.3.gz
/usr/share/man/man3/iswdigit.3.gz
/usr/share/man/man3/iswxdigit.3.gz
/usr/share/man/man3/isxdigit.3.gz
/usr/share/man/man3p/isdigit.3p.gz
/usr/share/man/man3p/iswdigit.3p.gz
/usr/share/man/man3p/iswxdigit.3p.gz
/usr/share/man/man3p/isxdigit.3p.gz
which git
which: no git in (/bin:/usr/bin:/sbin:/usr/sbin:/usr/local/bin:/sbin:/usr/sbin:/bin:/usr/bin)


yum install git
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile

  • base: mirrors.kernel.org
  • epel: mirrors.cat.pdx.edu
  • extras: mirrors.cat.pdx.edu
  • updates: mirrors.cat.pdx.edu
    Setting up Install Process
    Resolving Dependencies
    –> Running transaction check
    —> Package git.x86_64 0:1.7.4.1-1.el5 set to be updated
    –> Processing Dependency: perl-Git = 1.7.4.1-1.el5 for package: git
    –> Processing Dependency: perl(Error) for package: git
    –> Processing Dependency: perl(Git) for package: git
    –> Running transaction check
    —> Package perl-Error.noarch 1:0.17010-1.el5 set to be updated
    —> Package perl-Git.x86_64 0:1.7.4.1-1.el5 set to be updated
    –> Finished Dependency Resolution

Dependencies Resolved

================================================================================
Package Arch Version Repository Size

Installing:
git x86_64 1.7.4.1-1.el5 epel 4.5 M
Installing for dependencies:
perl-Error noarch 1:0.17010-1.el5 epel 26 k
perl-Git x86_64 1.7.4.1-1.el5 epel 28 k

Transaction Summary

Install 3 Package(s)
Upgrade 0 Package(s)

Total download size: 4.6 M
Is this ok [y/N]: Exiting on user Command
Complete!


What am I doing wrong?

Jack

Thanks again for you help guys, I was able to install git successfully using a different console app.

Thanks Andrechek! I tried everything you suggested until it finally worked. It’s strange that I couldn’t use the link to the GZ file directly in the virtualmin ftp or http field, but had to click & download it, then upload it. It’s always nice when a 5yo comment can still salvage your day! :wink: