Git module not working

Hi all, I’m having some problems with getting the Git Module to work with Virtualmin GPL 3.80 and was hoping there might be an expert around to help me out.

I just did a fresh install of Virtualmin on a VPS running CentOS 5.5. Everything worked fine as usual but for this installation I want to make use of the Git Repositories module.

I followed the guide in the documentation section, first by adding the EPEL repository and then trying “yum install wbm-virtualmin-git” but apparently no such package exists. As suggested, I then tried installing the module directly, which worked fine.

I was able to enable the plug-in and add a repository but when I click “browse repository” or go to I get an Internal Server Error. I was under the impression that this URL is mapped to webgit, which I thought would work properly regardless of how my repositories were set up.

I am currently deprived of sleep, which, compounded with my incredible stupidity may be the root of the problem but since I have no idea how Virtualmin implements this module I don’t even know where to start trying to fix it.

Any help would be massively appreciated.



You’re right that the package isn’t in there yet… I suspect the instructions for how to get git up and running were created faster than the actual packages needed for the git module :slight_smile:

I sent Joe and Jamie an email to make sure that’s in the works.

As far as the Internal Server Error goes – take a peek at your $HOME/logs/error_log file, what error are you seeing in there?


The YUM and APT repos have been updated to include this module now, so installing with yum or apt-get should work fine …


Your suexec log is located in /var/log/httpd/suexec.log. If you can pull up the corresponding entries in that log, that’d be great!


Hmm this is incredibly weird. I posted a reply with the error_log you asked for, which had a number of references to suexec. When I submitted the message it proceeded to the next page but didn’t appear to have sent my message. I tried refreshing the page, clearing my cache and even changing browser but it just seemed to have not been submitted correctly. I just assumed it was lost, which was quite annoying but I had no time to re-type it.

Now I come back and still cannot see the reply I typed (as I expected) but I can see your reply, which seems to be referring to it. Very strange indeed. I’ve attached a screenshot to better illustrate what I mean.

Anyway I digress. Here is the suexec.log

[2010-09-29 16:29:31]: uid: (500/xerosoft) gid: (500/500) cmd: gitweb.cgi
[2010-09-29 16:29:31]: command not in docroot (/var/www/git/gitweb.cgi)
[2010-09-29 16:31:46]: uid: (500/xerosoft) gid: (500/500) cmd: gitweb.cgi
[2010-09-29 16:31:46]: command not in docroot (/var/www/git/gitweb.cgi)
[2010-09-29 16:55:22]: uid: (500/xerosoft) gid: (500/500) cmd: gitweb.cgi
[2010-09-29 16:55:22]: command not in docroot (/var/www/git/gitweb.cgi)
[2010-09-29 16:57:24]: uid: (500/xerosoft) gid: (500/500) cmd: gitweb.cgi
[2010-09-29 16:57:24]: command not in docroot (/var/www/git/gitweb.cgi)
[2010-09-29 16:59:12]: uid: (500/xerosoft) gid: (500/500) cmd: gitweb.cgi
[2010-09-29 16:59:12]: command not in docroot (/var/www/git/gitweb.cgi)
[2010-09-29 17:00:47]: uid: (500/xerosoft) gid: (500/500) cmd: gitweb.cgi
[2010-09-29 17:00:47]: command not in docroot (/var/www/git/gitweb.cgi)
[2010-09-29 17:12:33]: uid: (500/xerosoft) gid: (500/500) cmd: gitweb.cgi
[2010-09-29 17:12:33]: command not in docroot (/var/www/git/gitweb.cgi)
[2010-09-29 17:12:42]: uid: (500/xerosoft) gid: (500/500) cmd: gitweb.cgi
[2010-09-29 17:12:42]: command not in docroot (/var/www/git/gitweb.cgi)
[2010-09-29 17:12:44]: uid: (500/xerosoft) gid: (500/500) cmd: gitweb.cgi
[2010-09-29 17:12:44]: command not in docroot (/var/www/git/gitweb.cgi)
[2010-09-29 20:12:03]: uid: (500/xerosoft) gid: (500/500) cmd: gitweb.cgi
[2010-09-29 20:12:03]: command not in docroot (/var/www/git/gitweb.cgi)
[2010-09-29 21:04:30]: uid: (500/xerosoft) gid: (500/500) cmd: gitweb.cgi
[2010-09-29 21:04:30]: command not in docroot (/var/www/git/gitweb.cgi)

It appears like the git module is mapping my /git path to the Apache default docroot instead of my domain’s home.

Is this a bug in the git module’s configuration or is it more likely something I’ve done to mess it up? Am I right in thinking the git module is a relatively new addition?

Thank you very much for your time and patience - your help is greatly appreciated.


I’ve seen this before - the fix is to remove the file /etc/httpd/conf.d/git.conf and then restart Apache. Unfortunately it contains an alias directive that overrides the gitweb.cgi that Virtualmin sets up.

I will add this to the docs.

Awesome, that fixed it. I was starting to wonder if it was supposed to be there but I wasn’t sure enough to delete it.

Big thanks Jamie and Andrey for your time and help.

By the way, I’m still not seeing the git module in the repositories.