Getting SpamAssassin to do its thing

I am tired of the deluge of spam I get daily, so I decided to give SpamAssassin a whirl. From VirtualMin->System Settings->Features and Plugins, I checked the boxes for both Spam filtering and Virus filtering. After this, to be ‘safe’, I rebooted the server.

Post reboot, I verified that SpamAssassin is running by entering ‘spamassassin -V’ at the command line. I also verified that /etc/procmailrc exists, but I could not find /etc/webmin/virtual-server/procmail (per the notes here: https://www.virtualmin.com/documentation/email/spam-av). Further, spam folders have not been created for each of the users on the (sole) virtual server and spam is still being delivered.

My guess is that there is a configuration step that I missed - could you please help me figure this out?

If it matters: webmin v1.730, virtualmin v4.13.gpl, CentOS v6.6

Thank you.

Howdy,

The other step you would want to perform is to enable it for the domains that should have access to it.

To do that, go into Edit Virtual Server -> Enabled Features, and there you can enable spam filtering.

-Eric

Thanks - clearly an important step!

After this one step, I did nto see any changes in behavior. I then restarted both the dovecot and postfix servers - will see if that helps.

While navigating to restart the servers, I noticed that there exists Webmin->Servers->Procmail Mail Filter, but that none of the boxes were checked. Do I need to do anything here?

If you are on Centos check this article it could help you to improve defense against spam: http://wiki.centos.org/HowTos/postfix_restrictions plus you could always turn on postgrey (greylisting).