Getting rid of unix username suffix in mail/FTP usernames

Hi Folks,

Need a bit of a hand here. I’m trying to add FTP (or e-mail) users to a domain. I’m finding that all new users have to have the unix account’s administration user / group name tacked on the end. EG for a new user named “fred” to be given access to unix account “xyz”, the login name becomes “fred.xyz” rather than what I want, which is simply “fred”.

I"m guessing that the suffix is so that different virtual servers can have the same usernames, which of course is desireable, but I have never seen this on any other host account I have had over the years. Is there any way around it?

I’m on CentOS 64 bit if that makes any difference.

Thanks.

Howdy,

Yeah, that’s correct – email and FTP accounts are created with a domain suffix like what you’re seeing.

While you can’t prevent it from adding a suffix for email and FTP users, you can configure how the suffix looks by going into System Settings -> Server Templates -> Default -> Mail for Domain, and setting “Format for usernames that include domain” to your preferred style.

-Eric

So is that a CentOS limitation or a Virtualmin limitation or a name based virtual host (as opposed to ip based) limitation or just why is the domain part required?

Actually, you can instruct Virtualmin to not (i.e. only when necessary) add the domain name to username, under System Settings -> Virtualmin Configuration -> Defaults for new domains, by changing the setting “Include domain name in usernames? Always / Only to avoid a clash”.

Help text says:

This option selects how usernames will be generated. By default, Virtualmin will use the base username requested, but if it clashes with an existing username it will append the domainname in the manner specified in the next option. If consistency is preferable, set this to “Always”, and all usernames within sub-servers will have the domain name appended.

Thanks for the information. That’s exactly what I needed.