Getting Fatal Error with auto installer.sh

Hello to all.
I try to install virtualmin with its auto installer.
I have ubuntu 14.04 LTS minimal x64 running on my server. Its a fresh install.

i use the codes

 wget http://software.virtualmin.com/gpl/scripts/install.sh -O /root/virtualmin-install.sh 

and

 sh /root/virtualmin-install.sh 

but everytime i get a fatal error. I add the virtualmin_install.log file to attachment.

https://www.virtualmin.com/files/virtualmin-install_19.txt

can someone help me pls

Howdy,

What kind of server is this, is it a dedicated server or VPS? And how much RAM do you have? You can determine that with the command “free -m”.

Lastly, I’m curious if running “apt-get update” continues the package installation that had began, and shows you a more specific error message.

The installer stopped at a fairly unusual place, so I’m wondering if maybe you’re seeing a resource issue if some kind.

-Eric

its a vps.

               total       used       free     shared    buffers     cached

Mem: 1024 870 153 129 0 761
-/+ buffers/cache: 109 914
Swap: 4096 0 4096
i dont get any error when i execute apt-get update and apt-get upgrade. if someone wants have a look i can give them root access

Howdy,

Hmm, if you’ve tried running “apt-get upgrade” and that worked – I’d be curious what happens if you re-run the install.sh script. It’s safe to run that a second time, and it’s possible it’ll work this time around if it was a resource issue.

-Eric

when i try run the script seccond time iget ddifferent error.
https://www.virtualmin.com/files/virtualmin-install (2).txt

What kind of VPS are you using there? Is it by chance OpenVZ?

If so, can you paste in the contents of your /proc/user_beancounters file?

-Eric

its not an openvz. its a vserver. andreychek do u use spkype. arslan.sonmez is my skype.

Howdy,

Do you by chance have the ability to give this vserver more RAM? I’d be curious if that resolved the issue.

-Eric