GeoIP Virtualmin 3.82 issue

I have installed all GeoIP requirements and downloaded the databases

GeoIP.dat for geoip
GeoIPOrg.dat for geoip_org_maxmind (renamed GeoIPASNum.dat)
GeoIPCity.dat for geoip_city_maxmind (renamed from GeoLiteCity.dat)

I verified that everything works correctly by executing manually:

/usr/share/awstats/wwwroot/cgi-bin/ -config=domain_name (but first I need to change the current directory to the directory that contains the dat file)

Everything works as expected. Great!

But unfortunately the scheduled awstats cron jobs don’t work if the geoip plugins are enabled. (AWstats report date is not updated).

May be virtualmin can not find the correct location of the dat files? I tried the following locations


I also tried

LoadPlugin=“geoip GEOIP_STANDARD /usr/local/share/GeoIP/GeoIP.dat”
LoadPlugin=“geoip_city_maxmind GEOIP_STANDARD /usr/local/share/GeoIP/GeoIPCity.dat”
LoadPlugin=“geoip_org_maxmind GEOIP_STANDARD /usr/local/share/GeoIP/GeoIPOrg.dat”


/etc/webmin/virtualmin-awstats/ domain_name

I am puzzled why the virtualmin cron jobs don’t work. Unfortunately there I could not find any logs that could help with the analysis.

Anybody has an idea how I could trouble shoot this?

I think I was able to fix it (but not able to figure out the why). I deleted the content of all /home/domain_name/awstats folders, and had virtualmin recreate the awstats*txt files again. Not sure what messed up the file permissions/structure in all domains. I suspect “manual execution of” interferes somewhat?