FTPd not working properly? Shows no files,directories on log in

Something weird is going on with FTP server after migration.
When I log in to any web site within the server it shows blank page - no directories/files.
ftp client - FAR MANAGER
tried normal mode/passive mode - same thing
Tried adding custom command “LIST -la” - nothing…

window log:
“entering passive mode…”
“200 type set to A” - (here it stalls for like 10 sec! it’s definitely nothing to do with connection speed)
“abort successful…”
blank page

What has to be checked to have FTP working properly?
I cannot update sites over this…


your firewall probably blocked the “passive ftp ports”?


You may also want to check out the “FTP Service Isn’t Working” question here, which discusses a kernel module you may be able to use to resolve that:


thats strange!
after running command “modprobe ip_conntrack_ftp” it works perfect
does it have to added to autorun somewhere though? what will happen after server reboot?

Oh nuts, you’re right, the documentation completely fails to mention how to make that work after a reboot :slight_smile:

I’ll have to fix that!

You do need to automate running that command on reboot… the typical way of doing that with a kernel module on CentOS is to add the module name to /etc/rc.modules, as described here:


On Debian/Ubuntu, you can just add it to /etc/modules.


I am on Centos 6.2 and there is no “/etc/rc.modules”

I am on Centos 6.2 and there is no “/etc/rc.modules”?

Yup! That’s normal, you can follow the instructiosn in the CentOS link above in order to create that file.


occasionally (once in 5 days or so) I have to do it again (“modprobe ip_conntrack_ftp”)
server hasn’t been rebooted or any service restarted
does this mod get unloaded somehow?

It shouldn’t! I’ve never heard of a module being unloaded… if you look at the “dmesg” output, do you see anything in that which suggests the module may be crashing?


dmesg gives me loads of in/out kernel iptables firewall messages
nothing about ftpd