FTP user can't login

I have a Virtualmin server with several virtualservers running on it. On one of those servers I created a new FTP user and tried logging in but what happens is that it gets connected and then immediately disconnected. In /var/logs/auth.log I found this

Mar 18 15:53:29 primary sshd[5482]: Accepted password for ftp@domain.com from port 13374 ssh2
Mar 18 15:53:29 primary sshd[5482]: pam_unix(sshd:session): session opened for user ftp@domain.com by (uid=0)
Mar 18 15:53:29 primary systemd: pam_unix(systemd-user:session): session opened for user domain by (uid=0)
Mar 18 15:53:30 primary systemd-logind[1022]: New session 9 of user domain.
Mar 18 15:53:30 primary sshd[5482]: pam_unix(sshd:session): session closed for user ftp@domain.com
Mar 18 15:53:30 primary systemd-logind[1022]: Removed session 9.

If I use the virtualserver login details (ones that are used to login at domain.com:10000) in ftp, it works fine. Also the root user also works fine. I tried creating ftp user on another Virtualserver and that had the same issue as well.

Same issue here. I haven’t been able to hunt it down and it’s driving me nuts!

I’m not sure if this will help but I had the same issues before on a pureFTP on a different panel, but the issue was, passive ports were not whitelisted and IPs are under NAT ( ForcePassiveIP for pureFTP or MasqueradeAddress for proFTP).

Wich OS
pure<>pro ftp ?
TLS on?

LOOKS LIKE SFTP / SSH has this setting exact same worked before and where there updates client or server ?

And so on

Updates clients , then also versions of encryptions protocols and ciphers and so on could be problem if with tls/ssl ?

With proftpd more log files are availeble as tls.log or so