FTP Schedul Backup failsure

Hi

If I try to save my virtual host to a network HD (iomega NAS 500) with FTP i got this error:

"Starting backup of 1 domains to //nethdd/BACKUP/Webserver on FTP server 192.168.2.4 …

Failed to connect to FTP server : CWD / failed : Failed to change directory.
Backup failed! See the progress output above for the reason why."

I have the rights to acces the directory, via command shell it works.

can anybody help me to solve this problem.

“See the progress output above for the reason why.”
Where can I find a detailed log file about this error?

thx in advance
opaque

Howdy,

What I would do is log into your FTP server, from your Virtualmin Server – and try to ‘cd’ into the exact directory that is setup in the Backup Schedule (ie, cut & paste the full directory name that is listed in there).

Upon doing that, does it work?

-Eric

[root@server1 ~]# ftp
ftp> open
(to) 192.168.2.4
Connected to 192.168.2.4.
220 Iomega StorCenter Network Hard Drive
530 Please login with USER and PASS.
530 Please login with USER and PASS.
KERBEROS_V4 rejected as an authentication type
Name (192.168.2.4:root): opaque
331 Please specify the password.
Password:
230 Login successful.
Remote system type is UNIX.
Using binary mode to transfer files.
ftp> ls
227 Entering Passive Mode (192,168,2,4,143,152)
150 Here comes the directory listing.
-rw-rw-rw- 1 ftp ftp 6148 Sep 03 14:43 :2eDS_Store
drwx–S— 4 ftp ftp 4096 Aug 05 13:04 :2eTemporaryItems
drwx–S— 41 ftp ftp 4096 Sep 03 11:03 Jobs
drwxrwxrwx 3 ftp ftp 4096 Jun 03 17:13 Network Trash Folder
drwx–S— 20 ftp ftp 8192 Sep 11 12:05 Preferences
drwxrwxrwx 3 ftp ftp 4096 Jun 03 17:13 Temporary Items
drwx–S— 4 ftp ftp 4096 Sep 15 12:15 Webserver
drwx–S— 12 ftp ftp 4096 Jun 04 17:26 diverses
226 Directory send OK.
ftp> cd Webserver
250 Directory successfully changed.
ftp> ls
227 Entering Passive Mode (192,168,2,4,104,126)
150 Here comes the directory listing.
-rw------- 1 ftp ftp 15364 Sep 07 09:34 :2eDS_Store
-rw------- 1 ftp ftp 483138 Sep 10 23:03 ServerBackup
-rw------- 1 ftp ftp 53943366 Sep 09 23:06 domain.at.tar.gz

Can you attach a screenshot of the “Destination and format” section of your Scheduled Backup that isn’t working?

Thanks,

-Eric

Here are some Screenshots

Howdy,

Okay, here’s what I’m seeing –

Whenever you logged in on the command line, you had tried typing “cd Webserver”:

226 Directory send OK. ftp> cd Webserver 250 Directory successfully changed.

However, in your screenshot, the directory that you have listed in there isn’t “Webserver”, it’s “/Webserver”.

Try it again from the command line, and use the “/” with your test, something like:

cd /Webserver

I suspect with that, you’ll see the same problem as the backup procedure is having :slight_smile:

-Eric

MacPro:~ opaque$ ftp
ftp> open
(to) 192.168.2.4
Connected to 192.168.2.4.
220 Iomega StorCenter Network Hard Drive
Name (192.168.2.4:opaque):
331 Please specify the password.
Password:
230 Login successful.
Remote system type is UNIX.
Using binary mode to transfer files.
ftp> cd /Webserver
550 Failed to change directory.
ftp> cd Webserver
250 Directory successfully changed.
ftp>

It works with “Webserver” not with “/Webserver” on the command line.

In the Virtualmin Interface nothing works.
See Screenshots: