FTP on Centos 6.3

HI,

great products, however I’m having some newbie issues.

Initially I installed Centos 5.8 and managed to get webim/vitualmin working correcty
in that I added domains, users, ftp users, could access the correct webpages and access via FTP. All good…
but discovered that 5.8 doesn’t come with PHP 5.3 and some applications I was planning to use need PHP 5.3.

After some research, I saw that installing php 5.3 on centos 5.8 was a very tricky thing.

So I re-installed Centos 6.3 (which comes with php 5.3.3) and re-installed vitualmin using the script and re-setup.

This time everything seems to work (so far as I have got) except FTP.

Connection established, waiting for welcome message... Response: 220 FTP Server ready. Command: USER xxxxxxxx Response: 331 Password required for xxxxxxxx Command: PASS ********* Response: 230 User xxxxxxxx logged in Command: OPTS UTF8 ON Response: 200 UTF8 set to on Status: Connected Status: Retrieving directory listing... Command: PWD Response: 257 "/" is the current directory Command: TYPE I Response: 200 Type set to I Command: PASV Response: 227 Entering Passive Mode ( 'my ip',131,247). Command: MLSD

in /var/log/messages

Nov 19 16:04:45 alcaeushosting proftpd[7329]: myip (::ffff:requestip[::ffff:requestip]) - FTP session opened.
Nov 19 16:04:45 alcaeushosting proftpd[7329]: myip (::ffff:requestip[::ffff:requestip]) - Preparing to chroot to directory ‘/home/alcaeushosting’

Any ideas?

Howdy,

I didn’t see an error in the above output – what problem is it that you’re having with accessing your system via FTP?

-Eric

It just hangs and times out…

But I have narrowed it down, the issue is with passive mode. If I use a simple ftp client or switch FleZilla to active it works.

I will continue to investigate, but is you have any ideas. (passive worked fine on the same box / router for Centos 5.8 - so it is either something I did slighlty wrong on setting up Virtaulmin/Webmin netweorking or a difference between Centos 5.8 & 6.3)

Howdy,

You may want to take a look at the last article in this link titled “FTP Service isn’t working”, I suspect that will resolve the issue you’re seeing:

https://www.virtualmin.com/documentation/web/faq

omg!!!

Why didn’t I guess that :slight_smile:

I just ran modprobe ip_conntrack_ftp

and it works like magic.

Just wish I knew that a few hours ago :frowning: