FTP Not working

I’ve setup a new installation of the Virtualmin Pro AMI on Amazon’s EC2 using ElasticFox.

First question, your instructions for port settings show us what to open using command line interface. I’ve opened the same ports using ElasticFox, but I don’t know what options to select for each of the port numbers. There are things like TCP/IP, HTTP, SSH, etc. to choose from along with a host and network series of IP addresses. Can you instruct in more detail what to choose on these settings?

Second question, despite the above, I can login with my Cyberduck FTP and see files, etc. but I can’t upload anything. It sometimes creates folders, but generally I can’t delete folders or put anything on the server. I’m unclear how to setup a SFTP connection.

Thus, I don’t know if my problem comes from the first or second question above. I’ve seen a few other threads about the FTP issue and ran some commands to no avail.

This is very frustrating, as without being able to upload the CMS and files, the server is useless.

Thanks for your help.

I have no idea. I’ve never seen the ElasticFox interface, so I’m not sure what you’re asking exactly. I also haven’t used FTP for much of anything in about a decade, so I’m not really sure the best way to troubleshoot it (I use ssh and the scp/sftp tools for file transfers).

The FTP problem sounds like either an active/passive problem, or a firewall that is causing problems.

Try switching your client from active to passive (or vice versa) and see if that resolves the problem.

If not, then go through the firewall settings, and make sure you have both ftp and ftp-data ports opened.

You may also need the ip_conntrack_ftp module to be loaded. Not sure if that’s possible on an EC2 instance…but it is needed for active FTP (I think it’s active; I never can remember which is which) in a NATted environment, which EC2 is.