FTP no longer working

I have been running Virtualmin for quite a few months now and appreciate the time it has saved me with setting up and managing domains.

I just had a client email me that FTP was not working. I checked for myself and it was not working. It had been working fine previously, and the only things that I have done are the updates, both to virtualmin and to CentOS. I don’t remember if there was an update to FTP or the firewall or not. It may be the firewall, due to the fact that I get the error, Connection refused. There is no info in the logs, which is what makes me suspect the firewall. I haven’t changed the firewall.

I looked around and wasn’t really able to find anything that may help me. I did look at the firewall rules and ftp and ftpdata are there, so that should not be a problem. Where do I look, what do I look for? Please help.



Active FTP also requires high ports to be open, not just ftp and ftpdata ports.

I usually just open up the firewall for all high ports (everything above 1023), but you could also use the stateful features of iptables to accept all RELATED and ESTABLISHED connections.

Thanks for the help Joe. I added a related and existing rule to the incoming section. This rule was already valid for the outgoing connections. It still doesn’t work. I applied the new configuration and tried to ftp in, but no luck.

I checked the messages log, and there isn’t anything in there stating that I even tried to connect, but I am still getting connection refused.

I will try a reboot. Shouldn’t need to, but I can.

This server is directly connected to a hub, which is connected to the modem, so there is no router in the way.

Any other suggestions?