FTP connection process is slow


i installed Virtualmin on Debian Etch and it seems that the installation is ultra fast and easy + i could not get any other Control Panel to work (the free ones) but Virtualmin just worked out of the box.

The only problem i have right now is that when a user tries to connect to ftp it takes about 15 seconds untill the connection is accepted. Is there any way to make that delay time a little bit shorter?

The log from Filezilla:

16:19:51 Status: Connection established, waiting for welcome message... 16:20:01 Response: 220 ProFTPD 1.3.0 Server (Debian) [xx.xx.xx.xx]

Cheers, rebrain.

Do you have similar issues with other services, such as SSH?

If you try to connect to your server via SSH, do you see a decent wait before you’re given a prompt?

One of the things I’d look into is to make sure DNS is working as expected on your box. For example, making sure /etc/resolv.conf has the correct DNS server and such.

Also, do any messages show up in the logs around the time you try to connect via FTP, such as in /var/log/messages and /var/log/syslog?

the contents of resolve.conf:

nameserver nameserver 91.121.31.XXX nameserver 213.186.33.XX

I changed some settings and installed the Slave DNS plugin. Right now I am having about 1 second delay, but this is more than ok.

Thank you for the support.

Well, typically, you’d have either “”, or some other set of nameservers.

In your case, it looks like you have both.

I might see if you have better results if you comment out those last two (or, if that doesn’t help, try just commenting out the first one and leaving the last two enabled).

Well, typically, you'd have either "", or some other set of nameservers.

In your case, it looks like you have both.

Multiples is usually fine, though using "forwarders" in the local BIND that point to the other two servers is the better approach.