FTP connection LIST timeout after upgrade to Virtualmin 4.01

Hi all,

I upgraded Virtualmin to version 4.01.

However I cannot get the directory listing working anymore.

Everytime I try to connect (active or passive mode) with Filezilla, I get the error:
Command: LIST
Error: The data connection could not be established: ETIMEDOUT - Connection attempt timed out
Error: Connection timed out
Error: Failed to retrieve directory listing

Any idea how to fix it?

Thanks per advance for your help

Note: I tried to connect in command line as well and I have the same issue.

I also have an other server with Virtualmin 3.96 (not upgraded yet) where the connection works perfectly.

Thanks per advance for your help


Well, Virtualmin doesn’t affect FTP connections, but it’s possible something else changed at the same time Virtualmin was updated.

FTP connections go through ProFTPd, so what we can do is review possible issues with it.

Are you using CentOS?

If so, what does this command output:

rpm -qa | grep proftp

Also, there’s a section here titled “FTP Service Not Working” at the end of the document:


It describes a workaround to the problem you’re seeing.



Thanks for your help. I ran this cmd: modprobe ip_conntrack_ftp and it fixed the issue.

Thanks for your answer and your time