Fresh Virtualmin install, strange problem!

Hello everybody!

From about 5 years I successfully maintaining the Debian server for my home business, thanks to Virtualmin.

I have 3 WordPress websites, I bought Themes for them,
but it turned out that to work properly, I must upgrade my Debian 5 to Debian 8.

I successfully installed Debian 8.2 and Virtualmin… But I now have a problem! I cant install Wordpress. It give me: Error establishing a database connection

This is wp-config.php file

  1. define(‘DB_NAME’, ‘database-name’);

  2. define(‘DB_USER’, ‘database-username’);

  3. define(‘DB_PASSWORD’, ‘database-password’);

  4. define(‘DB_HOST’, ‘localhost’);

The problem is in ‘localhost’!

My server is behind router.

My server hostname on fresh install server is NED.

My Fully qualified domain name on fresh install server is DomainOne.COM .

On DomainOne.COM I can install wordpress using ‘localhost’.

But on Domain Two.COM and DomainThree.COM nothing is possible!!!

For three days I am trying to find solution! Seven times reinstalled server and virtualmin. Fresh installs.

Three days my server is down…

I do not know what caused this problem.

With the old server I had no problems to install many WordPress sites on one IP using ‘localhost’.

I tried every combination to replace ‘localhost’: NED.DomainOne.COM,, NED, Externel IP and etc…

What I may be missing during configuration?

My root info:

System hostname: NED.DomainOne.COM (

Hostname and DNS Client: NED

On Checking Configuration the result is:

 Your system has 3.21 GB of memory, which is at or above the Virtualmin recommended minimum of 256 MB.

BIND DNS server is installed, and the system is configured to use it.

Mail server Postfix is installed and configured.

Postfix can support per-domain outgoing IP addresses, but is not currently configured to do so. This can be setup in the Postfix Mailserver module.

Apache is installed.

The following PHP versions are available : 5.6.17 (/usr/bin/php5-cgi)

Webalizer is installed.

Apache is configured to host SSL websites.

MySQL is installed and running.

ProFTPD is installed.

Logrotate is installed.

SpamAssassin and Procmail are installed and configured for use.

ClamAV is installed and assumed to be running.

Plugin DAV Login is installed OK.

Plugin AWstats reporting is installed OK.

Plugin Mailman is installed OK.

Plugin Protected web directories is installed OK.

Using network interface eth0 for virtual IPs.

Default IPv4 address for virtual servers is

Both user and group quotas are enabled for home and email directories.

All commands needed to create and restore backups are installed.

The selected package management and update systems are installed OK.

… your system is ready for use by Virtualmin.

Virtualmin Configuration > Networking settings:

Network interface for virtual addresses: eth0
Default virtual server IP address : From network interface
Default IP address for DNS records: Automatically detect external address

Any ideas or suggestions?

Thanks in advance to anyone who reads this!

The problem is solved!

The User Name for MySql data base was plovdivproperties, but MySql
saves it - plovdivpropertie ! For one litle “S” 3 days! :wink:

when you upgraded debian did you change versions of mysql? and do you know from what to what?

I made completely new Debian installation - version 8.2

My MySQL version is 5.5.47 - the original MySQL version for Debian 8.2. (No Change)


Just to clarify, are you saying it’s working now?

I do believe MySQL has size limits to it’s usernames though, your one username may be longer than MySQL is able to handle, so it stripped a character.


Yes, I now use shorter names for my MySql usernames. :wink: