Follow Symlinks when creating new accounts

Hi Guys

When creating new accounts, it seems Virtualmin “resolves” symlinked paths, rather than just using them.

For Example our /home/ directory is a symlink to /storage/remote/, rather than putting /home/ into the virtualmin and apache configs, it puts /storage/remote/. This causes problems for us as we’re in the process of transitioning our servers to a new storage layout and the paths to the symlinks will change.

I’ll now manually have to update the Virtualmin configs, but for future reference, is there anyway of getting webmin/virtualmin to use the symlink path rather than constantly resolving it?


I did some quick digging into the Virtualmin code, and found the place where it determines (initially) which home directory name to use.

Can you check what you have set in System Settings -> Virtualmin Configuration -> Defaults for new domains : Home Directory Base

Do you have the symlink or the resolved name there? Setting it to the second radio button and “/home” might help. If not, then the symlink resolution might be done somewhere later in the code.

Hi Locutus

Thanks for digging that out, I’ve just check and It is set to /home/ (the Symlink path) and the correct radio, so it must be elsewhere :S

Okay, then this is unfortunately a case for the coders to look into; going deeper into the code would be unfeasible for me (as in take much more time to understand it, than expert Jamie would need :slight_smile: ).