Fixed a bug. Couldn't access https://maindomain.com:1000

I couldn’t access https://maindomain.com:10000 after the automated install for Ubuntu 22.04. I fixed the problem by adding “certfile=/etc/webmin/miniserv.pem” to /etc/webmin/miniserv.conf. The line was missing from the file. And https wouldn’t work without it there. Might want to add to the bugs list.

SYSTEM INFORMATION
Ubuntu 22.04 REQUIRED
Latest REQUIRED
Latest REQUIRED
Related packages SUGGESTED

that should be port 10000 not 1000

This doesn’t really fix a bug, and doesn’t really identify a bug. We’ll need to reproduce the problem to fix it, as this is not a common issue…I’ve never heard of it.

Were there any errors during installation? My guess is that when the Virtualmin installer tried to generate a Let’s Encrypt cert for your system, something went wrong, but I couldn’t guess what without more information.

Yeah I meant 10000. It was just a typo. I fixed it.

I retested and i don’t think it’s a bug after all. My problem had to do with Cloudflare DNS not working with it when it’s cached. Might not like the port 10000. I couldn’t even get the page to load. But it was strange because after I added the certfile it opened up. So I thought I had fixed the issue. I took out the certfile=/etc/webmin/miniserv.pem line I added. And rebooted. And I was able to access the website. However the SSL doesn’t work if you go to https://maindomain.com:10000. I found out I had to go to https://host.maindomain.com:10000 for SSL to work. I see the SSL configuration on the lines:
ipcert_host.maindomain.com,.host.maindomain.com=/etc/ssl/virtualmin/171623939546606/ssl.cert
ipkey_host.maindomain.com,
.host.maindomain.com=/etc/ssl/virtualmin/171623939546606/ssl.key

But it look like the part that says *.host.maindomain.com might not be correct. Should it be *.maindomain.com instead so that I can acccess webmin using https://maindomain.com:10000 ?

I’m looking on automated installation instructions page here: Automated Installation | Virtualmin — Open Source Web Hosting Control Panel
And it does say to just use https://example.com:10000 to access webmin. And not the fqdn. So not sure if the instructions are wrong. Or if the installer did something wrong.

We will fix that, even though example.com is also a FQDN.

Thanks I wasn’t sure if I did something wrong. Maybe you could fix it by generating a wild card ssl for the root of the fqdn on install? I’ve been using ChatGPT for most of my support. And asked it how I could get the wild card SSL to work for the default domain. And it recommened using either the DNS validation using BIND option on the Let’s Encrypt tab or use the Cloudflare API since I’m using Cloudflare DNS. I tried the the DNS validation using BIND option on the Let’s Encrypt tab first. But it gave an error that said: “Requesting a new certificate for *.defaultdoman.com, defaultdoman.com, using DNS validation …
… request failed : Neither DNS zone or any of its sub-domains exist on this system”
This might be because I don’t have BIND running. Not sure. So I decided on using the Cloudflare API to generate the SSL instead. And got it to work. Now I have wildcard SSL for the default domain. Just had to enter the private key and cert files in Webmin Configuration . SSL settings.

I’d recommend against using wildcards. (And, I’d probably recommend against listening to ChatGPT, too much. It lies quite a bit. We’ve had a handful of folks get into pretty deep messes by following its advice without verifying it first. As a jumping off point for ideas, maybe it’s useful, but as a system administrator, it’s a hazard.)

True. It’s not always right. You have to be careful. I’m using the more advanced paid version of ChatGPT 4o and it for the most part it gets it right though. Great learning tool for anyone that wants to learn. Speeds up the process for me.

As long as it tells you the truth, you may find later on you need to learn how a generic approach is taken. I tested chatgpt by pasting some code that I authored… unfortunately chatgpt’s resume was totally wrong, so from my point of view I would not trust it

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.