Fedora 10 i386

Hi,

I was upgrading my test server from fedora 9 to 10 and came up with a missing dependency

Missing Dependency: httpd-tools = 2.2.11-2.fc10.vm is needed by package 1: httpd-2.2.11-2.fc10.vm.i386 (virtualmin)

I disabled the virtualmin repo so I could install but thought fedora 10 was supported which was why I was upgrading.

Mitch

Fedora 10 is indeed supported by Virtualmin Pro.

If you’re using Virtualmin Pro, I’d verify that you’re setup with the Pro repository and not the GPL one.

-Eric

Hi Eric,

I gather the repositories are the PRO ones (virtualmin and virtualmin-universal as below) there is a username and password in the baseurl

I reenabled and got errors about the dependency when I tried to do a yum update

[virtualmin]
name=Fedora Core $releasever - $basearch - Virtualmin
baseurl=http://user:pass@software.virtualmin.com/fedora/$releasever/$basearch/
enabled=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-virtualmin
gpgcheck=1

[virtualmin-universal]
name=Fedora Core $releasever - $basearch - Virtualmin Distribution Neutral
baseurl=http://user:pass@software.virtualmin.com/universal/
enabled=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-virtualmin
gpgcheck=1

Mitch

Installing package(s) with command yum -y install httpd …

Loaded plugins: refresh-packagekit Setting up Install Process Resolving Dependencies --> Running transaction check --> Processing Dependency: httpd = 1:2.2.9-1vm.fc9 for package: 1:httpd-manual-2.2.9-1vm.fc9.i386 --> Processing Dependency: httpd = 1:2.2.9-1vm.fc9 for package: 2:mod_ssl-2.2.9-1vm.fc9.i386 ---> Package httpd.i386 1:2.2.11-2.fc10.vm set to be updated --> Processing Dependency: httpd-tools = 2.2.11-2.fc10.vm for package: 1:httpd-2.2.11-2.fc10.vm.i386 --> Processing Dependency: apr-util-ldap for package: 1:httpd-2.2.11-2.fc10.vm.i386 --> Running transaction check ---> Package apr-util-ldap.i386 0:1.3.9-1.fc10 set to be updated ---> Package httpd.i386 1:2.2.11-2.fc10.vm set to be updated --> Processing Dependency: httpd-tools = 2.2.11-2.fc10.vm for package: 1:httpd-2.2.11-2.fc10.vm.i386 ---> Package httpd-manual.i386 1:2.2.11-2.fc10.vm set to be updated ---> Package mod_ssl.i386 2:2.2.11-2.fc10.vm set to be updated --> Finished Dependency Resolution 1:httpd-2.2.11-2.fc10.vm.i386 from virtualmin has depsolving problems --> Missing Dependency: httpd-tools = 2.2.11-2.fc10.vm is needed by package 1:httpd-2.2.11-2.fc10.vm.i386 (virtualmin) Error: Missing Dependency: httpd-tools = 2.2.11-2.fc10.vm is needed by package 1:httpd-2.2.11-2.fc10.vm.i386 (virtualmin) You could try using --skip-broken to work around the problem You could try running: package-cleanup --problems package-cleanup --dupes rpm -Va --nofiles --nodigest

… install failed!

I’m not sure what’s going awry there – you could always try telling it to upgrade both httpd-tools as well as httpd to see if that makes a difference.

Alternatively, you could just download the handful of http* packages from here:

http://software.virtualmin.com/fedora/10/i386/

And just upgrade them using rpm -Uvh http-*.rpm .

-Eric

Hi Eric,

I had the fedora-updates repository enabled when I first upgraded then I had turned it off which seemed to be causing the problems. I reenable it and am now able to install httpd

Mitch