FCGId error

I get these in my site:

[warn] (103)Software caused connection abort: mod_fcgid: ap_pass_brigade failed in handle_request function

What is that?

Howdy,

Do you clients see an error, or are you just noticing that issue in the logs?

Debian has a bug for that particular problem here:

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=537922

However, what they noticed is that the error only shows up if the user hits the stop button in the browser, or for some similar reason the page doesn’t actually fully load due to an issue on the client side.

-Eric

I think its only in logs.

Okay, but what are these:

[Tue Aug 17 10:09:45 2010] [warn] (104)Connection reset by peer: mod_fcgid: read data from fastcgi server error.

[Tue Aug 17 10:09:45 2010] [error] [client 88.115.*****] Premature end of script headers: index.php, referer: http://hoitajat.net/foorumi/topic/5615-lopputili/

[Tue Aug 17 10:12:34 2010] [warn] (103)Software caused connection abort: mod_fcgid: ap_pass_brigade failed in handle_request function

Any ideas with this? I cant use FCGId, error log is full of errors. This worked fine before with Debian, so it cant be debian bug.

Getting the error “Premature end of script headers” suggests the PHP script isn’t running properly. What exactly might cause that, that’s difficult to say… that often indicates a problem with the script itself.

For example, if the script were generating an error while it were executing, you’d get “Premature end of script headers”" in the logs.

Is there a way to enable additional debugging with your script? Some can be set to output additional debugging into info the logfiles.

Another option is to try CGI rather than FCGID, and see if the errors go away in that case. CGI still maintains the security benefit of suexec. You can switch to CGI by going into Server Configuration -> Website Options, and changing the PHP Execution Mode.

-Eric

CGI mode seems slow, and it cretaes tons of these erroros:

PHP Warning: PHP Startup: Unable to load dynamic library ‘/usr/lib/php5/20060613/memcache.so’ - /usr/lib/php5/20060613/memcache.so: cannot open shared object file: No such file or directory in Unknown on line 0

I dont even use memcache. No accelator in my script. I use IP.Board in my site.

It sounds like something, somewhere, is configured to try and load memcache. That’s likely occurring in a PHP config file such as php.ini.

Both fcgid and cgi mode use the same php.ini files, so cleaning this up might actually help with some of your other issues.

I’d look in either $HOME/etc/php.ini, or the various php.ini and related conf files under /etc/, for any lines that are attempting to load memcache, and you can just comment it out.

Alternatively, you could always install the PHP memcache module.

-Eric

/home/***/etc/php5/php.ini

or

/etc/php5/apache2/php.ini

Nothing memcache related. I have installed Xcache, but i dont use it in that virtual server.

Depending on your distro, there’s likely other dirs and PHP config files located in /etc/php5… one of those is likely to contain something that’s loading memcache.

Try running this command:

find /etc/php5 | xargs grep memcache

/etc/php5/conf.d/memcache.ini:extension=memcache.so
/etc/php5/conf.d/memcache.ini:[memcache]
/etc/php5/conf.d/memcache.ini:memcache.dbpath="/var/lib/memcache"
/etc/php5/conf.d/memcache.ini:memcache.maxreclevel=0
/etc/php5/conf.d/memcache.ini:memcache.maxfiles=0
/etc/php5/conf.d/memcache.ini:memcache.archivememlim=0
/etc/php5/conf.d/memcache.ini:memcache.maxfilesize=0
/etc/php5/conf.d/memcache.ini:memcache.maxratio=0

Yup, that looks like the culprit :slight_smile:

Try commenting all those lines out, that should solve the memcache loading error.

-Eric

Cant i just delete whole /etc/php5/conf.d/memcache.ini ?