FCGI systemctl processes are not disabled after disabling a virtual server

OS type and version Almalinux 9.2
Webmin version 2.101
Virtualmin version 7.7 GPL


I have a virtual server configured on FCGId as the PHP backend (PHP script execution mode=FCGId), using NGINX.

After disabling it I realized that processes where running anyway. See here:

678803 /sbin/fcgiwrap -s unix:/var/fcgiwrap/DOMAIN_ID.sock/socket
679271 /usr/bin/perl /usr/bin/php-loop.pl /bin/php81-cgi -b /var/php-nginx/DOMAIN_ID.sock/socket
679274 /bin/php81-cgi -b /var/php-nginx/DOMAIN_ID.sock/socket
679280 /bin/php81-cgi -b /var/php-nginx/DOMAIN_ID.sock/socket
679281 /bin/php81-cgi -b /var/php-nginx/DOMAIN_ID.sock/socket
679282 /bin/php81-cgi -b /var/php-nginx/DOMAIN_ID.sock/socket
679283 /bin/php81-cgi -b /var/php-nginx/DOMAIN_ID.sock/socket

I browsed the Boot and Shutdown panel and both units related to the domain where active and running:


Is this the expected behaviour? I was expecting both to be disabled and stopped.

Thank you!

Hi there!

I don’t know if this is the right forum, but I didn’t receive any answer. Am I doing it right?