FCGI not serving php pages...they download

I’ve scoured this forum looking for a solution. I’ve got one virtual domain, out of twelve, that only downloads the php file when you visit the site.

All my other domains work properly, with Wodpress installs, but something is wrong with this one.

I tried recreating the virtual domain, thinking it might solve the problem, but it persists. I read through all the fixes on the board, about the SET Handler directive, which is already commented out on the server. Is there anything else I should be looking at in regards to this?

I’ve tried checking the Virtualmin configuration for errors and it still doesn’t work. I also tried changing the php handler from FCGI to CGI wrapper with the same results. I’m running out of ideas.


Is there perhaps a .htaccess file in this domain that’s causing the problem? It’s possible that a .htaccess file could cause an issue with the PHP handler.

Another thing to check is to go into Limits and Validation -> Validate Virtual Servers, to see if it detects any problems with this one domain.

Lastly – if you’re still having issues after the above, what distro/version are you using?


Sorry for the delay in responding. The problem was on my browser end of things, as the fix I found in one of the other threads had actually made things right with PHP. Site worked find on another computer and clearing the cache made it load correctly for me.