FastCGI Wrapper for PHP option not showing up

Nice to be back in the virtualmin forums.

Managed to get all of virtualmin running with few hiccups.

Running on Freebsd 12.1 with Apache24 and PHP 7.3.20 installed.

All FastCGI components are installed as ports, configured and uncommented in http.conf.

One critical missing component, the “Default PHP execution mode” only reads “Apachemod_php (run as Apache’s user”

The FastCGI wrapper script and FCGId options are not available on this page.

Which configuration options, ports, or binaries need to be installed in order for these options to appear?

Welcome back, @JeremyHorland :slight_smile:

First, Virtualmin -> System Settings -> Re-check Configuration

Then in Virtualmin -> Server Configuration -> PHP Versions check to see if you have PHP 7.3.20 selected (you might have more versions of PHP than you realise).

Finally in Virtualmin -> Server Configuration -> Website Options do you see more radio buttons than before in PHP script execution mode?

Did exactly step by step.

There is only one version of php on server. The only option listed on Virtualmin -> Server Configuration -> PHP Versions which says “This virtual server is using the mod_php execution mode for PHP, such does not allow per-directory version selection”

in Virtualmin -> Server Configuration -> Website Options it has only the mod_php option

Also, in server templates, the only option is still mod_php

I am beaten. Perhaps someone else has an idea?

I appreciate the help.

Let’s mark this one closed!

I took a look at: virtual-server/ supported_php_modes

local $suexec = &supports_suexec($d);
if ($suexec) {
# PHP in CGI and fcgid modes only works if suexec does, and if the
# required Apache modules are installed
if ($apache::httpd_modules{‘core’} < 2.4 ||
$apache::httpd_modules{‘mod_cgi’} ||

So… took a look at httpd.conf

<IfModule !mpm_prefork_module>
LoadModule cgid_module libexec/apache24/

LoadModule cgi_module libexec/apache24/

The LoadModule statements for the cgi module were commented out.

Two quick deletes and a reload…

The option appeared.


This topic was automatically closed 4 days after the last reply. New replies are no longer allowed.