Failing to restart Apache

Hi,

For some reason, after creating a new virtual server, Apache refuses to restart. The error log shows:

/usr/sbin/httpd: symbol lookup error: /usr/lib/perl5/vendor_perl/5.8.8/i386-linux-thread-multi/auto/Apache2/ServerUtil/ServerUtil.so: undefined symbol: ap_get_server_banner

My guess is that the Perl and the httpd versions are conflicting. The only way I could get around this problem was to reinstall VM, which is a no-no on a production server.

Any cue about what could be doing this?

Thanks.

you may want to look into this bugreport.

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=503375

For some reason, one of the yum repositories I installed would try to update my version of mod_perl to one that would conflict with Apache. Darn. Went back to the plain old vanilla Centos repositories, which seems to have brought my web server back to normal behaviour.

I have the same issue now as well. Is there a solution to getting apache to restart? I am running CentOS 5x but the machine also uses the Fort Systems repo for MailScanner so maybe I have a perl conflict here as well?

I am at a critical state now since the hosting running mailscanner is also a web hosting server and I have many sites down now due to a perl problem following an upgrade of mailscanner using the fsl-beta repo. If anyone can help or make any suggestions which might be able to get apache back up I would be greatful.

After this upgrade, apache fails to start now? This is a system running virtualmin as well and from the looks of the bug report below, something to do with missmatched perl repos.

The error in /var/log/http/error_log is…

/usr/sbin/httpd: symbol lookup error: /usr/lib/perl5/vendor_perl/5.8.8/i386-linux-thread-multi/auto/Apache2/ServerUtil/ServerUtil.so: undefined symbol: ap_get_server_banner

If you aren’t using mod_perl, you could always disable that Apache module.

But yeah, it’s possible that you ended up installing a version of Perl or Apache that is causing some conflicts…

-Eric

Any one can help me pls coz i have the same error and my server is down now.

[Wed Aug 04 16:27:45 2010] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec) /usr/sbin/httpd: symbol lookup error: /usr/lib/perl5/vendor_perl/5.8.8/i386-linux-thread-multi/auto/Apache2/ServerUtil/ServerUtil.so: undefined symbol: ap_get_server_banner

Howdy,

Any idea what may have changed prior to receiving that error message?

If you aren’t using mod_perl, you can always disable that in order to prevent Apache from starting up. Since that error is related to mod_perl not being able to load, disabling mod_perl would fix it, if that’s an option.

However, if you happen to know what changed, we may be able to offer some input into the root cause of the issue…

-Eric

How, exactly, Eric? Because the people who host my server seem stumped.

OK, here’s what they did, and my Apache is running again, so I am happy:

yum remove mod_perl

yum install --disablerepo=utterramblings mod_perl

and reinstall mod_perl from Centos

Thanks,
K

Howdy,

How, exactly, Eric? Because the people who host my server seem stumped.

Well, the key there would be to just prevent the mod_perl module from loading when Apache starts up… there should be a LoadModule line in either /etc/httpd/conf/httpd.conf or somewhere in /etc/httpd/conf.d/ that loads mod_perl. I don’t know off the top of my head which it is, but it’d be a matter of looking through those for the line that loads mod_perl, and then commenting it out.

However, what you guys did sounds like it’s working, that’s good news!

-Eric

Hi,

Try issuing the following command…

yum install mod_perl-devel.i386

I am a web developer and had the same issue as yours. I struggled for several hours before i fixed it using the above command.