Failed to start BIND 9.9 - Webmin

I can’t start BIND 9.9.0 through the Webmin 1.585.

However, when running the following command it starts correctly:
/etc/rc.d/init.d/named start

I’m running the CentOS 6.2

ps auxw | grep named

named 3715 0.0 3.0 282124 15804 ? Ssl 00:00 0:00 /usr/sbin/named-sdb -u named
root 4559 0.0 0.1 103232 856 pts/1 S+ 00:43 0:00 grep named

whereis named

named: /usr/sbin/named /etc/named /etc/named.conf

What am I missing?
I’m not sure what I’m doing wrong.


With Centos 6.x make sure BIND is not running in chroot. You can do this in the BIND module config.

i’m having the same issue and i want to do the above.

I attached my bind configuration and if i read this thread correctly all i need to do is choose “none” for “Chroot directory to run BIND under”

do i need to change any other settings?


is named under chroot directory? Choose No
that should be about it.

when i do this and then save i get the message below…which should i choose…i’m assuming “Setup as an internet name server, and download root server information”

everything seems to be working ok as is so i’m afraid to screw with it!

BIND version 9.7.3 Start BIND
Search Docs…

The primary configuration file for BIND /etc/named.conf does not exist, or is not valid. Create it?

Setup nameserver for internal non-internet use only

Setup as an internet name server, and download root server information

Setup as an internet name server, but use Webmin’s older root server information

IF you have BIND running it shouldn’t ask those questions… unless the config doesn’t point to the right location.
Are you running under centos 6.x as well?

yeah centos 6.x

that’s what i thought…it must be running or i would be having issues though right?

If BIND is not running it is likely that your websites aren’t visible when you rely on DNS on the virtualmin box …

Per haps in your case some paths are incorrect (below is what I have on centos 6.2)
Webmin-server-BIND dns server-module config- System configuration

Full path to the named.conf file /etc/named.conf
Full path to the named executable /usr/sbin/named
Default PID file location(s) /var/run/named/

you can compare this to your own settings and locations to see if such files exist

thanks i’ll check…the server is running great all sites are visible…mail working fine…that’s why i’ve been afraid to mess with it!

hey ronald my paths were the same…here’s the problem…

Virtual servers i added before changing the bind settings suggested in this thread are still visible to the web and email and ftp work just fine…BUT when i try to look at the dns info for those sites i get an error in webmin saying config file can’t be found.

HOWEVER after changing the bind settings to not run in chroot…when i add a virtual server it installs ok but is not visible to ftp or the web…BUT when i look at those servers dns info and records in webmin i see all the zone files and everything looks good but like i said they are invisible to the web.

any suggestions?


anybody have any ideas or directions where i should be looking?

thanks in advance,

did you check the domains with to see early errors

ok…here are links to two domain names added as virtual servers with virtualmin run through was added BEFORE i changed the settings recommended in this thread…it seems to be finding everything ok…no red flags… was added AFTER making these changes…lots of red flags like it can’t find the info it needs?

i have since reverted back to the original settings but the issue persists…

i’m thinking it was setup originally without using bind? is that possible? and then i changed it to start using bind when making the changes and my problems started…almost like there are two named.conf files in different directories or something…i am confused…

thanks for the help!

Did you restart BIND?
Is the zonefile for that domain correct and did you check the paths to /etc/named.conf?
You can also try in the BIND module to click on Addresses and Topology and add your IP’s of the nameservers.

i did restart bind and the zonefile records look correct to me…

here’s the thing…when i look in the bind module i only see zone files for the two domains that i added after the chroot change…and these are the only two dopmains that aren’t working. I don’t see any zone files for all the other domains added before the chroot change and yet all those domains are working no problem.

it sounds like old domains are created in the /chroot directory and the new ones a few levels up.
I would probably move all zonefiles to /var/named and then make sure the paths in the modules config are correct.

thanks ronald…that makes sense to me…i’ll look into it.

i am feeling stupid…i can’t get this worked out…i tried moving the newly added domains (that aren’t working) to the named folder where the domains that were working are located…still didn’t work.

i am about to lose a client (at least one) because i can’t seem to make their sites visible.

any more suggestions…i don’t want to goof up all the domains that are currently working so i’m nervous to try to much.

never figured this out and when i tried to do a backup to my second harddrive it failed because it couldn’t find the domains…so now i ca’t even back everything up before i start messing with the settings…

any ideas?

ok here’s is my game plan…please stop me if this sounds wrong!

since the domains that are working are IN the chroot directory and the domains that don’t work (only 2 at the moment) are NOT in the chroot directory…i am going to delete the two domains outside of chroot…then set my paths within webmin to point to the correct directories (under chroot) and then reinstall the domains that weren’t working.

Does this sound ok?

thanks in advance,