Failed to save scheduled backup : Missing or invalid FTP server

When seeking to schedule a remote backup I get the above message (or missing or invalid ssh server as the case may be).

I have over several hours testing entered the name of the ftp server in every conceivable form, with trailing slash for absolute path and without, with real absolute path from top level (though it is going to shared hosting), with and without ftp. in server name, with and without trasport ftp://, with and without port number, as IP address etc., with and without colon between domain name and directory path. The ftp server does work with desktop ftp clients. What is the correct format for entering a valid FTP server in Virtualmin’s scheduled backup settings, please?


It sounds like something strange is going on there – is there any chance you could post a screenshot of that screen?

Normally, it’s just a matter of entering a hostname or IP address, that’s not usually a field that causes problems.


If you mean the error page, the frame contains nothing but white with the following words.

Failed to save scheduled backup : Missing or invalid FTP server

Return to previous page

Should I look for a Virtualmin error log somewhere?

Sorry, I meant that I’d like to see what the Schedule Backup screen looks like with the information filled out.


not sure it adds much. I also tried it as a separate schedule (rather than additional destination) and tried pointing to a different server.

BTW upload gave error message on your forum
warning: Parameter 2 to date_form_alter() expected to be a reference, value given in /home/virtualmin/public_html/includes/ on line 2930.

Thanks for the screenshot!

It looks like in the “FTP Server” field, that it has both an FTP server and the path listed.

Rather than that – list just the FTP server name in your FTP Server field, and place the path in the “File On Server” field.

After doing that, are you able to save your scheduled backup?


Hi Eric

Thanks. This does not help. I have tried every way of entering the ftp server, with and without path. Addding a path to a directory or a path to a file name under ‘File on Server’ (and leaving it out of server name) makes no difference to the error message.


Well, I don’t seem to be able to reproduce the problem you’re seeing – I was able to add an FTP backup destination on my own system.

So seeing what you have there is going to be the only way we’ll figure this out :slight_smile:

Can you post another screenshot of your current backup schedule screen?



This is how it looks before the failed attempt to add an ftp destination. It works for on-server backup.

Well, what we’d need to see are the FTP settings that you’re trying to add that don’t work properly.

I was able to add both a local and an FTP backup destination on my own system here, so what I was planning to do was copy the exact formatting you had there to try and reproduce the error you’re getting.


I am not sure what you mean about ftp settings. I could give you the ftp server name, user, password. To some extent these are visible on the first screenshot. However, without giving actual domains, the format is:
FTP Server:
File on server: /home/mydirectory/backup
Login as user: (a real ftp account I created)
Password: [correct password]

I have tried this with details of two real servers which I can ftp files into from desktop, and can ftp into via cli from the remote server where Virtualmin is installed. Both return the ‘Missing or invalid FTP server’ error screen when trying to save a scheduled backup.