Failed to save mailbox

Hi all, i’m complete newbie here. And here’s my problem. If anyone help, i’ll be glad.
On my FreeBSD 6.2 box, i have domains restored from a backup. When i try to add a new mailbox user, i get an error as below:

Failed to save mailbox : The username user@domainname.com is longer that the maximum allowed on this system (16 characters)

I couldn’t resolve the issue. My configuration is:
FreeBSD 6.2 i386
Webmin 1.380
Usermin 1.300
Virtualmin GPL 3.48, master admin mode

P.S: i don’t have a problem about the issue on my old Fedora5 box (which i got backups on) with the same configuration above.

Thank you.

FreeBSD has a built-in limit of 16 characters for usernames. Nothing we can do about that…though you could rebuild parts of FreeBSD to permit longer usernames. It’s been discussed here in the forums a couple of times, along with the steps for rebuilding with long username support.

The other option would be to restore your users under a different (shorter) name. It pretty much rules out user@domain.tld style usernames, because almost everything will be too long…so you’ll have to get a bit more creative. Something like “joe.virt” or similar.