failed to request certificate : no virtual host matching was found


I try to create a let’s encrypt certificate for but I have this error :

failed to request certificate : no virtual host matching was found


Can you explain me more, I think you have to clear you redirection on root folder.

I just create a let’s encrypt certificate with Webmin, it work for, but not for

where is the root folder ?

It was spam and not a real reply.

Check you have a dns entry for, and that if you visit it with a web browser that it goes to the directory you expect.

@noisemarine Its a spam? I really don’t know…but this forum don’t have moderator for that?

@pol2095 Please explain more your error, when you get this message, when tried to create a new cert to ftp.domain.tld? Did you have a DNS record type ‘A’ with name ‘ftp’ pointing to ‘IPv4 address of you host’?

When I try to connect to on port 80 in web browser I have this message error :
You don’t have permission to access / on this server.

I think “let’s encrypt” had the same problem

Is-it to possible to add an index.html on this url like a web ftp ?

I tried to add in “/home/mysite/public_html/ftp/index.html”, but it doesn’t work

Did you have virtual host setted on apache config file? Like that:

DocumentRoot “/home/mysite/ftp/public_html”
ServerAlias ftp

i work thanks

But you have created a directory in that folder?

mkdir /home/mysite/ftp
mkdir /home/mysite/ftp/public_html
chown -R mysite:mysite /home/mysite/ftp

It work thanks

I created a virtualhost for port 443 for, and SSL is broken, is broken too

Did you point the certificate and key file on Apache config? Like that:

SSLEngine on
SSLCertificateFile “/home/mysite/ssl.cert”
SSLCertificateKeyFile “/home/mysite/ssl.key”

Thanks I have missing this