Failed to read systemd units

Ubuntu 18.04 Server LTS
All packages up to date.

I was trying to set up DKIM and it said that it failed to save the conf file.
Failed to save DKIM settings : Failed to read systemd units

So I went to System > Bootup and Shutdown and it fails to list anything and errors out with " Failed to read systemd units" as well. That seems to be the root error that is causing the error saving the DKIM conf file, but I have no idea where to even start with that one.

I ran systemctl list-units --full --all and it listed everything (as far as I know), including an opendkim entry

opendkim.service loaded active running OpenDKIM DomainKeys Identified Mail (DKIM) Milter

There are plenty of other services that are listed as “not-found inactive dead” but I don’t know what to look for here.

Any ideas?

Thanks for your time!

I manually edited /etc/postfix/main.cf and set up the milter sockets to match the settings in opendkim.conf like so

smtpd_milters = inet:localhost:8891
non_smtpd_milters = inet:localhost:8891

Now when I go to Virtualmin > Email Settings > DomainKeys Identified Mail my dkim keys are listed and it appears to be working correctly (still have to test the DKIM but sending a mail).

So that part seems to be solved. I still have the “Failed to read systemd units” issue when I go to the Bootup/Shutdown page.