Failed to open /home/mail/ for writing...

I’m getting this error… please help… I’m really new to this.

Creating mailbox for administration user …
… mailbox failed : Failed to open /home/mail/ for writing : Bad file descriptor at …/ line 982.

What should I do?

Looks like the file is bad.

What distro is this ?

CentOS Linux 5.2

Actually why is it trying to write to /home/mail/ ?

Unless your user is mail which you can’t have cause its a system accuount you will get this error.

i see… so do you have any suggestions how to fix this?

actually I just followed instructions on how to configure postfix here…

I really don’t know how to fix this. Any ideas?

Well I hope VM was smart enough to not even setup anything otherwise you now have a broke system.

Oh geez ignore that HOWTO !!! If you installed using the script you were all done.

That was written BEFORE they fixed the backup issues not backing up email correctly.

Undo everything you did if you can.

I tried changing the spool directory with /var/spool/mail… I believe that fixed it.

Well, I guess VM was really smart. Woooot!.


In fact ignore all docs there – read and use the ones at instead.

We keep those up-to-date.

Great! Thanks


I also filed a bug for this for doc cleanup