Failed to install Virtualmin on CentOS 5.0

I failed to install Virtualmin on CentOS 5.0. Following is the messenge. Any suggestion is appreciated.

Checking for curl or wget…found /usr/bin/curl -s -O
Checking for perl…found /usr/bin/perl
Loading log4sh logging library…
INFO - Started installation log in virtualmin-install.log
INFO - Checking for fully qualified hostname…
INFO - Hostname OK: fully qualified as test.chinahot.com
INFO - Installing serial number and license key into /etc/virtualmin-license
INFO - Loading OS selection library…
INFO - Download of http://software.virtualmin.com/lib/oschooser.pl Succeeded.
INFO - Loading OS list…
INFO - Download of http://software.virtualmin.com/lib/os_list.txt Succeeded.
INFO - Operating system name: CentOS Linux
INFO - Operating system version: 5
INFO - Installing virtualmin-release package for CentOS Linux 5…
INFO - Disabling SELinux during installation…
error: /usr/share/rhn/RPM-GPG-KEY: import read failed(-1).
INFO - Download of http://:@software.virtualmin.com/rhel/5/x86_64/virtualmin-release-latest.noarch.rpm Succeeded.
error: open of <!DOCTYPE failed: No such file or directory
error: open of HTML failed: No such file or directory
error: open of PUBLIC failed: No such file or directory

Looks like downloading of password protected files is failing. Let’s take it over to a private issue in the issue tracker, or email me off-list, and we’ll get it figured out (I’m going to want to see the value of SERIAL and KEY in your install.sh, as it looks like maybe they’re blank for some reason, but not on the forum).

I also got the same sequence of error. I tried wgetting the file again and it’s running OK past that point. However, I still got one error again:

error: /usr/share/rhn/RPM-GPG-KEY: import read failed(-1)

Is it anything to worry about?

The /usr/share/rhn error is fine. We’re trying to import a bunch of different keys, and not all of them exist.

There’s probably other stuff broken now, as I totally botched the repositories yesterday while cleaning them up. But I’m getting them straightened out, slowly but surely.

But, anyway, if the rest of the install ran without errors and if when you login the config check runs without error, you’re in good shape.

The only problem in running the config check was an error with clamav not finding files. I disabled clam for now. Was that a problem with the repositories? I ran yum update clam*, but nothing was available.

Same Issue

I went back to my order and in addition to being able to download the install.sh it has a copy paste link for direct download to your server. I used it and was able to install properly. Originally I just right clicked and copied the link for the down load and did a wget copied link on my server and end up with the above issue.