*Failed to install module phpini 

Operating system: Debian Linux 9
Kernel and CPU
Linux 4.9.0-12-amd64 on x86_64
OS version:
Webmin 1.960

Failed to install module from https://download.webmin.com/download/modules/phpini.wbm.gz : Module phpini requires Webmin version 1.962 or above

Why are you trying to install phpini? It’s a standard module, included in the Webmin package.

The standard modules in that repo are always dependent on the latest Webmin version, which is problematic, but…well, you don’t need to install those modules because they are included in Webmin.

And, though this should happen almost never, I’ve filed a ticket and hopefully Jamie can fix that dependency to only rely on stable Webmin versions, or only bump when necessary to actually satisfy API dependencies. https://github.com/webmin/webmin/issues/1328

But, I think in your case you should probably explain what you’re trying to do that led you to even trying to install a module that you should already have…seems like probably some confusion somewhere about something. What are you actually trying to do (trying to install phpini was for some purpose I presume)?

What I want is to change the version of PHP and it doesn’t give me an option because I don’t have the module installed

The PHP Configuration module (phpini) is installed by default. However, it might be disabled on Webmin > Webmin Users > username > Available Webmin Modules page (ACLs).

If for any odd reason the module phpini is missing, you don’t need to install the module separately, and all you need is to reinstall currently installed webmin package.

By the way, we are about to push Webmin 1.962 and Usermin 1.812 to our Virtualmin repos.

OK thank you very much.
I have managed to do it but I have already seen why that option did not come out. What I wanted was to change the version of PHP with “PHP Versions”, but I have seen that this option shows it “Virtualmin” and not “Webmin” … is there any way to do it with “Webmin”?

… to change PHP version for virtual server? :slightly_smiling_face:

yes, change the PHP version. Wordpress tells me that I have version 7.0 (7.0.33-37 + 0 ~ 20201103.43 + debian9 ~ 1.gbp25a3d7) and I want to go to version 7.4

You probably should have installed Virtualmin, instead of just Webmin. But, you can’t really safely run the Virtualmin installer on a system that’s already in production.

Webmin doesn’t really manage the stuff that would allow version selection for PHP, and phpini is for managing one PHP configuration file, nothing to do with selecting versions for a specific virtual host. Virtualmin exists to make managing websites and all the related stuff easy…Webmin is a general purpose systems management tool.

Installing Virtualmin also installs Webmin, and is a set of Webmin modules and configuration and package dependencies.

Then you’ll need to install version 7.4. (But, I’d recommend you proceed with caution on replacing a major component of your deployment.)

That’s actually not part of Webmin or Virtualmin. Though Virtualmin does install some PHP 7 version if the OS doesn’t provide one (some old distros only have PHP 5.x, so we enable some vetted third party repo to install a PHP 7.x version).