Failed to extract source : Sub-directory eticket-1

I was trying to install eTicket into a domain.
I specified to use ‘eticket’ under the public_html directory.

However, when the installer runs, I get this error: "Failed to extract source : Sub-directory eticket-1.7.2 was not found"

Any idea what I can do to get this installed?

I tried creating a sLink in my public_html directory that was named ‘eticket-1.72’ and pointed to ‘eticket’. But that didn’t help.<br><br>Post edited by: tbirnseth, at: 2008/11/20 07:47

Sounds like a bug!

I’d go ahead and file a bug report here:

Hmm… Filed the bug at the suggested link.

Is there a work-around? Can you explain what it’s looking for so I can possibly do this manually?


Don’t know if this helps but the current version of eTicket is 1.7.3 and the script has 1.7.2. I modified the script to have versions “1.7.2”, “1.7.3” and then tried installing using the 1.7.3 version. But the same error was generated (except it now couldn’t find directory eTicket-1.7.3).

I looked at the scripts and tried to trace my way through it but don’t know what the ‘cache’ location is so I can’t go see what’s really there.

A new version of Virtualmin is rolling out tonight or tomorrow. Since you’ve filed a ticket, I suspect it’ll be fixed in that release.

That would be very cool. I submitted a ticket on the variable ${PREFIX} too (but via the submit support ticket interface). Will that one be addressed too? Right now, for ‘’ ${PREFIX} equals ‘’ where it should be ‘ez-ms’ (or if you’re translating valid DB chars ‘ez_ms’. Either way would be acceptable though I’d think the ‘ez-ms’ value would be best and leave any other translation up to the level that needs to translate characters.