Failed to create virtual server : Failed to work out externally visible IP address

I installed the latest Virtualmin to an openvz vps running Ubuntu 16.04.1. All went well until I tried to add a virtual server. I received the above error message. I’ve installed Virtualmin dozens of times over the last decade and this is the first that I have seen this problem. I know that I have to go into System Settings/Virtualmin Configuration/Network and change the venet0 to venet0:0 to get the right external IP address. Sometimes I forget to do this but Virtualmin lets me change it later and propagates the change to the virtual servers.

I tried to set the interface during the install, but as it alway has, it fails. Most likely it doesn’t like the colon. See:

Device “link” does not exist.
[WARNING] Unable to determine IP address of primary interface.
Please enter the name of your primary network interface:
./ 450: ./ log_debugPrimary address detected as not found

I first made the change to venet0:0 before I tried to create the virtual server and it failed with the error message, so I configured it back to venet0 and it still failed.

The status of your system is being checked to ensure that all enabled features are available, that the mail server is properly configured, and that quotas are active …
Your system has 1024 MB of memory, which is at or above the Virtualmin recommended minimum of 256 MB.

Using network interface venet0:0 for virtual IPs.

IPv6 addresses are available, using interface venet0:0.

Default IPv4 address for virtual servers is

Virtualmin could not work out the default IPv6 address for virtual servers on your system. You will need to update either the Network interface for virtual addresses or Default virtual server IP address fields on the module configuration page.

… your system is ready for use by Virtualmin.

That was after i set the network settings/network interface for virtual addresses

The network settings:
I can’t copy/paste and image, so it’s here.

This all used to work. One thing to note is that above it said “IPv6 addresses are available, using interface venet0:0” but that’s not true. See:

venet0:0 Link encap:UNSPEC HWaddr 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00
inet addr: P-t-P: Bcast: Mask:

Another issue is that one of the first warnings I received was that my memory was less than 1 GB and the install might fail. However the output from the reconfiguration seemed to think 256 MB was the minimum. But that’s not important since it did install fine.

Thanks for any insight.

Anyone? I’d really like to get this server off the ground.

I rebuilt the VPS and started over. No good. I can’t create a virtual server. At this point, I think Virtualmin is broken for OpenVZ VPS systems.

Since virtualmin won’t install on OpenVZ, I purchased a KVM system running Ubuntu 16.04 server.

It won’t install here either

I got

▣▣□ Phase 2 of 3: Installation
Installing Webmin [ :heavy_check_mark: ]
Installing Usermin [ :heavy_check_mark: ]
Installing fail2ban [ :heavy_check_mark: ]
Removing nginx (if installed) before LAMP installation. [ :heavy_check_mark: ]
Removing unneeded packages that could confict with LAMP stack. [ :heavy_check_mark: ]
Installing postfix [ :heavy_check_mark: ]
Installing virtualmin-lamp-stack [ERROR] Failed with error: 100
[ ✘ ]

[ERROR] Something went wrong. Exiting.
[ERROR] The last few log entries were:
Recommends: clamav-freshclam but it is not going to be installed
Recommends: clamav-docs but it is not going to be installed
Recommends: clamav-testfiles but it is not going to be installed
Recommends: sasl2-bin but it is not going to be installed
Recommends: php5-mysql but it is not going to be installed
Recommends: php5-mbstring but it is not installable
Recommends: jailkit but it is not going to be installed
Recommends: postgrey but it is not going to be installed
Recommends: php-mysql but it is not installable
Recommends: php7.0-mysql but it is not installable
Recommends: libconfig-inifiles-perl but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
Installing virtualmin-lamp-stack: [2019-05-17 21:54:10 BST] [ERROR] Failed with error: 100
[2019-05-17 21:54:10 BST] [ERROR] Something went wrong. Exiting.
[2019-05-17 21:54:10 BST] [ERROR] The last few log entries were:

I guesss I’ll have to look for an alternative to virtualmin.

I found the problem. The service provider installs 14.04 even if you select 16.04 from the rebuild menu. It doesn’t install on 14.04 apparently.