Failed to create virtual server : Dictionnary word

Hi Dear!

I’m a new virtualmin user and i need some help.

I have 2 problems.

The first one is about the BIND module.

When i try to active it, it tell me that i need to put inside the dns server list but when i do that, it doesnt work.

The adress disappair automaticaly when i apply the modifications to the server.

It work only if i dont apply the modifications but when i restart the computer, it disappair anymore.

The second problem is when i try to create a new server.

I have the following error:

Failed to create virtual server : Is a dictionary word

I dont understand. It was working when i tried to create one before.

So, if someone can help, i will appreciate it a lot.


Hi there…
I have the same problem with adress… I added, and when I restart the server it disappair. I’ve changed that the server have a static IP from router, andnow its works perfectly… So my problem was in DHCP.


Thanks for your help eustachy but i already had these settings.

I also tried to disable the dhcp server in the router but have the same problem.

In the static ip section, did you put for the gateway?

In my case, it’s the router ip (

Another ideas?


The dns server problem has been fixed with the following shell command:

restorecon -v /etc/hosts

As soon as it was did, it came possible to add to the dns server list.

For the "word list" problem… isnt fixed… so if someone can help me, i will appreciate.


resolvconf has been installed thus over-writing any changes made.

resolvconf is a default package that is installed in mandriva and debian distro’s and its meant for ppl that use dial up or dynamic dsl/cable.

If you have your own BIND and IP you do not need this installed and you can delete it.

BTW restorecon does not "fix" anything per-se.

From the man page:
This program is primarily used to set the security context (extended attributes) on one or more files.

“Is a dictionary word” refers to the user PASSWORD not the server it self. You can’t use words like “dog” or “password” since they are not secure.


I will take a look in that way but just like that, i tried to use an unusual password like SdRJ545DSvKc45 and it told me the same thing…

is it normal?


No that isn’t normal at all then.

What’s the domain name you are trying to create ?

Can you post the log when the error happens?

I have few domain names hosted at and i want to be able to host their respective websites at my home.

The domain name i tried to use is

For the log, i will post it here later in the evening.

Thanks again!

That’s really weird. Please post that log when you can for us.

Here is the log!

Error: No word lists can be found for the language "en_US".
Error: Is a dictionary word


This is very wrong…

File a bug report @

Actually ignore that…

Install aspell !! You have no dictionaries installed on your box.

If you’re talking about the perl module “Text::Aspell”, i did it yesterday without succes…

what distro is this ?

Fedora 8

Oh… You do know that FC is always beta code right? So anything can and does go wrong in that distro.

That said you MUST have aspell installed with the US dictionary.

I will try to install it in the evening and i’ll come back to tell you if it’s ok.

For the stability of Fedora Core, i eard about the same you said but a couple of weeks ago i didnt knew it.

My first goal was to see if linux is better than windows for hosting and i agree totaly!


Wich free distro is the best one?

Is there a lot of differences between FC and that disto?

Thanks and Regards!

You’ve enabled strong password requirements in your PAM configuration, but you’re trying to create a user with a crappy password. Don’t create users with weak passwords, or turn off the strong password requirements (known as in the PAM configuration files).

CentOS is the free Red Hat-based distro that we recommend for servers. (Red Hat-based means “a lot like Fedora”, so if you’re used to Fedora, you’ll be used to CentOS immediately)

But, this is just a misconfiguration. Has nothing to do with the distribution of Linux you’ve chosen.

Ok but is it safe for me to continu to use Fedora 8 if all is working or there’s a lot of security lacks in it and it’s better to switch for CentOS as soon as it’s possible?

For the password, like i said, i tried to use an strong and unusual password like FRey123nDGFde353R and it didnt work.

Thanks for the support!